LC_ALL causes Slashdot display incorrectly in Mozilla 1.0

RESOLVED DUPLICATE of bug 159328

Status

()

RESOLVED DUPLICATE of bug 159328
17 years ago
16 years ago

People

(Reporter: voidcartman, Assigned: alecf)

Tracking

({intl, qawanted})

Trunk
x86
Linux
intl, qawanted
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0rc3) Gecko/20020523
BuildID:    20002052309

slashdot.org news pictures are aligned left but they have to be aligned on the
right.

Reproducible: Always
Steps to Reproduce:
1.Open www.slashdot.org



Actual Results:  News pictures are aligned left

Expected Results:  They have to be aligned right
(Reporter)

Comment 1

17 years ago
Created attachment 84896 [details]
Snaphot of slashdot

Updated

17 years ago
Summary: Slashdot isnt rendered correctly by Mozilla 1.0 rc3 → Slashdot isn't rendered correctly by Mozilla 1.0 rc3
(Reporter)

Updated

17 years ago
Summary: Slashdot isn't rendered correctly by Mozilla 1.0 rc3 → Slashdot isn't displayed correctly by Mozilla 1.0 rc3

Comment 2

17 years ago
WFM on Windows NT on build 2002052306 (1.0 RC3)

Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.0rc3) Gecko/20020523

Comment 3

17 years ago
wfm with rc3 and 2002052322 trunk on linux

Comment 4

17 years ago
Adding the allign="left" to the inner table or td seems to `fix` this.
(Reporter)

Comment 5

17 years ago
I can confirm that "Adding the allign="left" to the inner table or td  fix the
issue."

Comment 6

17 years ago
Confirming.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 7

17 years ago
Created attachment 84912 [details]
Tar package of the site

Comment 8

17 years ago
Hmm, I unpacked attachment 84912 [details] in a local directory, and things still look
okay for me (I'm using a trunk build). Have you done any tinkering with your
profile settings? (I'm not sure what would cause floats to lay out this way, but...)
Keywords: qawanted
(Reporter)

Comment 9

17 years ago
i rm  -rf ed ~/.mozilla and started with a  vanilla profile still same

Comment 10

17 years ago
Checked the slashdot site and layout of page looks correct. WFM using the Linux
branch (2002-05-24-09 1.0.0) and OS X branch (2002-05-23-05 1.0.0). 
(Reporter)

Comment 11

17 years ago
I checkout from trunk and compiled build 2002052419 still the same can be based
on any *external* libs?
(Reporter)

Comment 12

17 years ago
This bug doesnt show up in Mozilla 1.0 rc2 so i did ldd mozilla-bin for both Rc
2 and Rc 3 and comprated them and saw that rc2 has two more libs than rc3 that are

libXi.so.6 => /usr/X11R6/lib/libXi.so.6 (0x1591d000)
libstdc++-libc6.2-2.so.3 => /usr/lib/libstdc++-libc6.2-2.so.3 (0x15b73000)

Maybe this helps some...

Comment 13

17 years ago
WFM with build 2002052306 under Windows ME.

Comment 14

17 years ago
WFM (RC3 on Linux).

Mozilla/5.0 (X11; U; Linux i586; en-US; rv:1.0rc3) Gecko/20020523

Comment 15

17 years ago
WFM, linux trunk official build as well as home-brew CVS with gcc-2.96-98 and
optimize=O2.

Sounds like a local configuration error -> invalid.
(Reporter)

Comment 16

17 years ago
Tried with already compiled binaries , and ones compiled with -02,-03 and no
optimizations still same.

Comment 17

17 years ago
Weird. Did you delete cache before loading the site with the official builds?
(Reporter)

Comment 18

17 years ago
Yes really weird I deleted cache & deleted profiles still no luck. I am starting
to think that some external library may affect this behaviour but cant figure
out what.
(Reporter)

Updated

17 years ago
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → INVALID
(Reporter)

Comment 19

17 years ago
As far as this bug only seen on my machine and i got 1-2 segfaults on other
program i resolve this to INVALID. Thnaks for the help though.

Comment 20

17 years ago
Changing QA Contact
QA Contact: petersen → moied

Comment 21

17 years ago
verified
Status: RESOLVED → VERIFIED
(Reporter)

Comment 22

16 years ago
I am re-opening bug because I found the reason why I see it how fix it and
reproduce it. Thing is the LC_ALL variable in /etc/profile if you open
/etc/profile and set the LC_ALL variable to something other than POSIX like set
it to tr_TR . Logout login then go to slashdot site is dispplayed wrong and some
submit buttons are unclickable if you set back the LC_ALL vraible to POSIX its
all ok.

This only applies to Rc3+ , Rc2 and older builds dont see this weird behaviour.
And a fast workaorund is adding export LC_ALL=POSIX to mozilla start-up script.

I think this is related to the patch that is about using local unix charset
defined in system thats why rc2 is immune but rc3+ doesnt. 

P.S : It would be good to add this to release notes.
Status: VERIFIED → REOPENED
Resolution: INVALID → ---
(Reporter)

Updated

16 years ago
Summary: Slashdot isn't displayed correctly by Mozilla 1.0 rc3 → Slashdot isn't displayed correctly by Mozilla 1.0

Updated

16 years ago
Keywords: intl
Summary: Slashdot isn't displayed correctly by Mozilla 1.0 → LC_ALL causes Slashdot not display incorrectly in Mozilla 1.0
setting my LC_ALL to fr_FR, no problems at all.
setting my LC_ALL to tr_TR, I can see the bug...

thereforce I suspect this have to do with *some* locales, but not all :)
mmm.  So it sounds like we could be using C library functions that are
locale-dependent.
(Reporter)

Updated

16 years ago
Summary: LC_ALL causes Slashdot not display incorrectly in Mozilla 1.0 → LC_ALL causes Slashdot display incorrectly in Mozilla 1.0
(Reporter)

Comment 25

16 years ago
This  still exists in Mozilla 2002081611 on Linux. Is there is a progress on
this bug ?
Giving to alecf since I suspect the tolower/toupper removal he was going to do
for another bug will probably fix this as well.
Assignee: attinasi → alecf
Status: REOPENED → NEW
Component: Layout → String
(Assignee)

Comment 27

16 years ago

*** This bug has been marked as a duplicate of 159328 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.