[Wayland] Configure WebRender on X11

RESOLVED FIXED in Firefox 62

Status

()

RESOLVED FIXED
10 months ago
9 months ago

People

(Reporter: stransky, Assigned: stransky)

Tracking

(Blocks: 1 bug)

Trunk
mozilla62
Points:
---

Firefox Tracking Flags

(firefox62 fixed)

Details

Attachments

(1 attachment)

(Assignee)

Description

10 months ago
Configure WebRender on X11, we depend on GLX backend right now.
(Assignee)

Updated

10 months ago
Blocks: 635134
Comment hidden (mozreview-request)

Comment 2

9 months ago
mozreview-review
Comment on attachment 8983339 [details]
Bug 1466775 - [Wayland] Configure WebRender on X11,

https://reviewboard.mozilla.org/r/249236/#review256968

::: commit-message-44f42:1
(Diff revision 1)
> +Bug 1466775 - [Wayland] Configure WebRender on X11, r?jhorak

I'm not sure if the changelog describe the problem there.

You're doing this change because you want to initialize WebRenderer not only for GLX but also for EGL? If so, please fix the commit message.
Attachment #8983339 - Flags: review?(jhorak) → review+

Comment 3

9 months ago
Pushed by stransky@redhat.com:
https://hg.mozilla.org/integration/autoland/rev/3447515d62c9
[Wayland] Configure WebRender on X11, r=jhorak
(Assignee)

Comment 4

9 months ago
mozreview-review
Comment on attachment 8983339 [details]
Bug 1466775 - [Wayland] Configure WebRender on X11,

https://reviewboard.mozilla.org/r/249236/#review256978

::: commit-message-44f42:1
(Diff revision 1)
> +Bug 1466775 - [Wayland] Configure WebRender on X11, r?jhorak

I do the change to configure WebRender when MOZ_X11 is set which generally means we build Firefox with X11 support. Before this change it depended on GLX.

Comment 5

9 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/3447515d62c9
Status: NEW → RESOLVED
Last Resolved: 9 months ago
status-firefox62: affected → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla62
You need to log in before you can comment on or make changes to this bug.