Closed Bug 1466814 Opened Last year Closed Last year

iOS sync integration tests are failing whilst waiting for weave:service:setup-complete

Categories

(Firefox :: Sync, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
Firefox 62
Tracking Status
firefox-esr52 --- unaffected
firefox-esr60 --- unaffected
firefox60 --- unaffected
firefox61 --- unaffected
firefox62 --- fixed

People

(Reporter: davehunt, Assigned: tcsc)

References

(Blocks 1 open bug)

Details

(Keywords: regression)

Attachments

(1 file)

The Firefox iOS sync integration tests are using TPS to sign into Firefox Accounts and perform an initial sync. Recently, the tests have started to fail whilst apparently waiting for weave:service:setup-complete.

We're expecting TPS to sign into Firefox Accounts and perform an initial sync. The signing in appears to work (we see a notification stating that sync will start shortly), however the sync does not complete and the test ultimately fails.

If you manually click to sync in the open instance of Firefox, then the test continues on. If you do nothing then eventually the Firefox instance will close and the test will fail.

The last few lines in the TPS log are:

> 2018-06-05 06:10:30.067 CROSSWEAVE INFO: ----------event observed: fxaccounts:onlogin
> 2018-06-05 06:10:30.068 CROSSWEAVE INFO: Logging into Weave.
> 2018-06-05 06:10:30.764 CROSSWEAVE INFO: Setting up wait for weave:service:setup-complete...

This suggests that the call to waitForSetupComplete in https://searchfox.org/mozilla-central/rev/292d295d6b084b43b70de26a42e68513bb7b36a3/services/sync/tps/extensions/tps/resource/tps.jsm#1191 never completes.

I used mozregression to determine a regression range, which concluded that https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=a90972d695291bea4560ee5a8da77398ca9b42b1&tochange=1c6cfeb419c3157fc3dd6ae564358f7af8ca9cd1 is the cause of the regression, which is bug 1409208 and at least related to sync, so it could potentially be related.
:tcsc has this affected the TPS tests? I'm not sure where to see the results. Any ideas?
Flags: needinfo?(tchiovoloni)
Assignee: nobody → tchiovoloni
Flags: needinfo?(tchiovoloni)
Comment on attachment 8983614 [details]
Bug 1466814 - Remove the manual login call from TPS, since we'll log in anyway, and shouldn't be holding the sync lock

https://reviewboard.mozilla.org/r/249466/#review255656

Thanks!
Attachment #8983614 - Flags: review?(markh) → review+
Pushed by tchiovoloni@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/4db37ec137d6
Remove the manual login call from TPS, since we'll log in anyway, and shouldn't be holding the sync lock r=markh
https://hg.mozilla.org/mozilla-central/rev/4db37ec137d6
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → Firefox 62
You need to log in before you can comment on or make changes to this bug.