Closed Bug 1467040 Opened 2 years ago Closed 2 years ago

All default search engines gone in latest non-en-US nightlies

Categories

(Firefox :: Search, defect)

defect
Not set
normal

Tracking

()

VERIFIED FIXED
Firefox 62
Tracking Status
firefox-esr52 --- unaffected
firefox-esr60 --- unaffected
firefox60 --- unaffected
firefox61 --- unaffected
firefox62 blocking verified

People

(Reporter: irvin, Assigned: mkaply)

References

Details

(Keywords: regression)

Attachments

(3 files)

Checked with latest zh-tw nightly (2018-06-05), the problem does not exist on latest en-us build. 

(1) All of the default search engines are gone. 
(2) You cannot click into search settings from preference panel, no response.
(3) Search related features are all broken, such as URL search engine or Search bar at home screen

If user upgraded from an older profile, the user-added search engine stays but all default is also gone.
confirmed just broken since latest nightly build: 

broken: 2018-06-05-22-01-58-mozilla-central-l10n/
normal: 2018-06-05-14-10-53-mozilla-central-l10n/
Summary: All default search engines gone in zh-tw nightly → All default search engines gone in latest non-en-US nightlies
Bug 1437942 has been backed out.
Blocks: 1437942
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Duplicate of this bug: 1467032
Respun builds work correctly
Status: RESOLVED → VERIFIED
Duplicate of this bug: 1467115
Duplicate of this bug: 1467120
Target Milestone: --- → Firefox 62
I have managed to reproduce this issue using Firefox 62.0a1 buildID: 20180605220158.

The issue is verified as fixed using Firefox 62.0b7 buildID: 20180709172241 and Firefox 63.0a1 buildID: 20180711221812  on Windows 10 x64, Ubuntu 16.04 LTS and macOS 10.14. The default search engines are now correctly displayed and used for the zh-TW builds. The preferences section now correctly displays the search section.
Please don't reset tracking flags.
You need to log in before you can comment on or make changes to this bug.