Closed Bug 1467169 Opened 3 years ago Closed 2 years ago

tsvgx regression with WebRender from SVG-as-a-reference-frame

Categories

(Core :: Graphics: WebRender, defect, P1)

defect

Tracking

()

RESOLVED WONTFIX
Tracking Status
firefox62 --- disabled

People

(Reporter: mstange, Unassigned)

References

(Blocks 2 open bugs)

Details

(Keywords: regression, Whiteboard: [gfx-noted])

This is the WebRender-specific part of bug 1464046.


Talos has detected a Firefox performance regression from push:

https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?changeset=133a13c44abedac2e448d315a32068ce1a5568f4

Regressions:

 17%  tsvgx linux64-qr opt e10s stylo     328.21 -> 385.57
  8%  tsvg_static linux64-qr opt e10s stylo54.73 -> 59.19

You can find links to graphs and comparison views for each of the above tests at: https://treeherder.mozilla.org/perf.html#/alerts?id=13394


In bug 1464046 comment 6, Jeff reported that this regression only manifests when using software OpenGL.
David, could you help find someone to own, or investigate this please?
Flags: needinfo?(dbolter)
This will be worked on as part of bug 1416652, which aims to eliminate the WebRender vs non-WebRender regression on this test. The specific regression that this bug was filed about does not affect 62 because it's WebRender-only and WebRender is not turned on by default yet.
Flags: needinfo?(dbolter)
Ah, thanks Markus. Let's mark it as disabled for 62 then.
Priority: -- → P1
Whiteboard: [gfx-noted]
By itself this regression is not a release blocker. Bug 1416652 is the release blocker, and fixing this is one of the possible ways to address that, but it's possible we can address that in other ways as well.
Priority: P1 → P2
Priority: P2 → P3
Priority: P3 → P4
Moving to stage-wr-next because (as Kats says) it doesn't block release.  We can move it back if we decide we need it to fix 1416652
Blocks: stage-wr-next
No longer blocks: stage-wr-trains
Priority: P4 → P1

tsvgx performance is now totally different than it was 8 months ago.

Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.