--app option to run web applications in "app mode" Feature Request

RESOLVED DUPLICATE of bug 1283670

Status

()

enhancement
RESOLVED DUPLICATE of bug 1283670
11 months ago
11 months ago

People

(Reporter: nathan, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 months ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:60.0) Gecko/20100101 Firefox/60.0
Build ID: 20180516032328

Steps to reproduce:

I want to use Firefox to run desktop web apps similar to Google's Chrome --app functionality. When running firefox --app='myurl.tld' the browser should open to a specified url without toolbars.

The purpose is for a site-specific browser uses for myself and work-related web applications. Plus, numerous other people have requested similar needs for various web based tools.

I acknowledge this is a duplicate request of original bug 1283670 but since it has been marked as "Won't Fix" and I am the original submitter, I am re-submitting a new request. This is a much desired feature. Please reconsider!


Actual results:

Feature does not exist

Updated

11 months ago
Severity: normal → enhancement
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 months ago
Component: Untriaged → General
OS: Unspecified → All
Hardware: Unspecified → All
Resolution: --- → DUPLICATE
Duplicate of bug: 1283670

Comment 2

11 months ago
(In reply to Nathan O'Brennan from comment #0)
> I acknowledge this is a duplicate request of original bug 1283670 but since
> it has been marked as "Won't Fix"

First of all, please don't knowingly file duplicates. If for some reason a report should be reopened, you can make your argument in a comment there, and maybe set the NeedInfo flag for the person who closed it.
Secondly, bug 1283670 was never closed. The "status-firefox57" tracking flag is set to "wontfix" because the feature can't make it into that version (the current release version is 60).
You need to log in before you can comment on or make changes to this bug.