Very long words disturb page width

VERIFIED DUPLICATE of bug 99457

Status

()

VERIFIED DUPLICATE of bug 99457
17 years ago
17 years ago

People

(Reporter: hc, Assigned: attinasi)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Comment 1

17 years ago
If there is a very long unbrakable string usually an URL like the one in the
first comment of this bug report, it increases the width of the whole section
which it is part of.

This can lead to pages where the user is forced to scroll left and right just to
read each single lines, because it now exceeds the screen width.

It becomes even more troublesome if the user increases the font size (CTRL-+)
which I often do to compensate for the high resolution (1280x1024) i use.

To illustrate this problem compare the screen width of these two pages, and try
increasing the fonts (View->Text zoom->Larger) on both and compare again.

http://www.theregister.co.uk/content/23/25418.html

http://www.theregister.co.uk/content/3/25411.html

One solution that would overcome the main problem of readabillity while not
breaking the long word/string, could be to NOT change the "width" of the page
but allow "real" long unbreakable strings to have a widther single line and
still add a left/right elevator if needed, then return to the unchanged "width"
again on the next line.

Comment 2

17 years ago
Isn't this a dupe of bug 95067 ? See also bug 99457

Comment 3

17 years ago
Changing QA contact to Moied
QA Contact: petersen → moied
(Reporter)

Comment 4

17 years ago
My point is that (no matter if long words being wrapped or not) THE PAGE WIDTH
should NOT BE CHANGES.

I can not judge from those two bug reports (95067 and 99457) if they would solve
my problem.

My problem is with all the other text being difficult to read - NOT the long
words themselves.

Comment 5

17 years ago

*** This bug has been marked as a duplicate of 99457 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 6

17 years ago
Verified dup of 99457
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.