Closed Bug 1467731 Opened 2 years ago Closed 2 years ago

Digitally signed binary certificate verification hits the network

Categories

(Firefox :: General, enhancement, P1)

Unspecified
Windows
enhancement

Tracking

()

RESOLVED FIXED
Firefox 62
Tracking Status
firefox62 --- fixed

People

(Reporter: ccorcoran, Assigned: ccorcoran)

References

Details

Attachments

(1 file)

WinVerifyTrust() can hit the network looking for cert revocation data, and in some cases take a very long time to return. For our purposes this is not needed, so we should add WTD_CACHE_ONLY_URL_RETRIEVAL, preventing network activity caused by this API.
Status: NEW → ASSIGNED
Comment on attachment 8984406 [details]
Bug 1467731: Prevent WinVerifyTrust from hitting the network;

https://reviewboard.mozilla.org/r/250238/#review256684
Attachment #8984406 - Flags: review?(aklotz) → review+
Pushed by aklotz@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/6b21d717e213
Prevent WinVerifyTrust from hitting the network; r=aklotz
https://hg.mozilla.org/mozilla-central/rev/6b21d717e213
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 62
You need to log in before you can comment on or make changes to this bug.