Not all extensions are synced across devices

RESOLVED FIXED in Firefox 63

Status

()

defect
--
major
RESOLVED FIXED
Last year
10 months ago

People

(Reporter: johan.bjornehall, Assigned: markh)

Tracking

({nightly-community})

63 Branch
Firefox 63
Unspecified
All
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(firefox62 wontfix, firefox63 fixed)

Details

Attachments

(3 attachments)

Some extensions are not synced across devices, for example (but not limited to): 

- uBlock Origin (https://addons.mozilla.org/en-US/firefox/addon/ublock-origin/)
- Emoji Box (https://addons.mozilla.org/en-US/firefox/addon/emoji-box/)
- Ghostery (https://addons.mozilla.org/en-US/firefox/addon/ghostery/) 

Examples of extensions that can successfully be synced:

- Emoji Cheatsheet (https://addons.mozilla.org/en-US/firefox/addon/emoji-cheatsheet/)
- Unpaywall (https://addons.mozilla.org/en-US/firefox/addon/unpaywall/)

Reproducible by installing and try to sync all or selected extensions above to another computer.
Flags: needinfo?(markh)
The sync is between Windows and Linux machine and both computers are running latest Firefox Nightly.
Version: 61 Branch → 62 Branch
Version: 62 Branch → 63 Branch
Do we need some sort of debug logs for closer examination to make any progress in with this issue?
Sorry for the delay here.

(In reply to kartongsaft from comment #0)
> Some extensions are not synced across devices, for example (but not limited
> to): 
> 
> - uBlock Origin
> (https://addons.mozilla.org/en-US/firefox/addon/ublock-origin/)
> - Emoji Box (https://addons.mozilla.org/en-US/firefox/addon/emoji-box/)
> - Ghostery (https://addons.mozilla.org/en-US/firefox/addon/ghostery/) 

Sadly I can't reproduce this uBlock Origin and Ghostery both sync fine for me (and I didn't try Emoji Box)

Logs would be helpful - if you install https://addons.mozilla.org/en-US/firefox/addon/about-sync/ it will configure Sync to get "trace" logs and also log even when Sync succeeds. It will also show you what is on the server for your addons, which might help us pinpoint what is going wrong.

Note however that just syncing now might not demonstrate the problem in the logs (as sync will probably think nothing needs to be done for addons) - what would be most useful would be to reproduce the problem with a different addon, and getting the logs from both devices.

(FWIW, there's also bug 1456027, which has symptom related to syncing the enabled and disabled state of addons, but I'm not sure they are the same bug - although I guess it could be if you repeatedly removed and readded the addons with the issue - do you remember doing that? I also can't actually reproduce that either, but I can see strangeness in the code which might explain it - but can't see anything that would explain the entire addon being missed as part of a sync.
See Also: → 1456027
After deleting the device from Firefox Sync (through https://accounts.firefox.com), deleting profile folder, sign in to Firefox Sync and then repeat the same step on the Windows machine, I was able to sync all extensions between the machines except Emoji Box. 

Further troubleshooting with About Sync showed that Emoji Box is synchronized with the server, but was unable for some reason to be installed onto the Windows machine due to a validation error (see attached screenshot).

Is this a bug? Does it have to do with the extension in particular? Can I somehow manually manipulative my data in Firefox Sync to solve this issue?
Posted image validation error.JPG
1531493684365   Sync.AddonUtils INFO    Skipping install of add-on because missing sourceURI: {369b4c1b-94a5-46ce-9301-d18120875adc}
1531493684365   Sync.Engine.Addons.Store INFO   Add-on skipped: {369b4c1b-94a5-46ce-9301-d18120875adc}

It seems that a property sourceURI is missing in the extension. Should I talk with the developer?

This though don't explain why I couldn't sync my extensions in the first place.
Depends on: 1476177
Thanks - the problem with EmojiBox seems to be a recent bug in Firefox - I opened bug 1476177. However, if doesn't explain the other 2 addons you mentioned in comment 0, so it would be great if you could try again to reproduce that.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: needinfo?(markh)
Duplicate of this bug: 1456027
I have tried to install and sync Ghostery and uBlock Origin on the Windows computer + Merge Windows (https://addons.mozilla.org/en-US/firefox/addon/merge-window/), Simple Translate (https://addons.mozilla.org/en-US/firefox/addon/simple-translate/) and Tab Counter Plus (https://addons.mozilla.org/en-US/firefox/addon/tab-counter-plus/) on the Linux computer. None of these extensions will make it to the opposite device.

AdNauseam (https://addons.mozilla.org/sv-SE/firefox/addon/adnauseam/) on the other hand, had no issue replicate between these computers.

I searched through the logs, but couldn't find anything related to the sync issue, but I do have a screenshot from About Sync.
Depends on: 1481355
No longer depends on: 1481355
This will be fixed for the vast majority of users by bug 1456027.

However, in my testing I discovered an edge-case - it may not end up fixed for users who previously had an addon installed in this profile but no longer do, and where the addon manager's cache of addons was either disabled or deleted or found to be corrupt - and one of my test profiles had exactly that scenario!

So I'll fix that in this bug.
Assignee: nobody → markh
Status: NEW → ASSIGNED
Comment on attachment 8998424 [details]
Bug 1467904 - allow addons to be installed if the addon manager's addon cache is outdated. r?lina

Lina Cambridge (she/her) [:lina] has approved the revision.
Attachment #8998424 - Flags: review+
Pushed by mhammond@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/9cfa0cc67011
allow addons to be installed if the addon manager's addon cache is outdated. r=lina
https://hg.mozilla.org/mozilla-central/rev/9cfa0cc67011
Status: ASSIGNED → RESOLVED
Closed: 11 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 63
Is this something you wanted to request Beta approval on?
Flags: needinfo?(markh)
Flags: in-testsuite+
(In reply to Ryan VanderMeulen [:RyanVM] from comment #16)
> Is this something you wanted to request Beta approval on?

Thanks Ryan. The regression was addressed in bug 1476177 which has been uplifted, and this bug is just fixing an edge-case that's been around for quite some time, so I don't think it's necessary to uplift this.
Flags: needinfo?(markh)
I saw that this bug changed status to RESOLVED, but I'm still experience issues. I can't for example not sync Merge Windows (https://addons.mozilla.org/en-US/firefox/addon/merge-window/) and Emoji Box (https://addons.mozilla.org/en-US/firefox/addon/emoji-box/).
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(In reply to kartongsaft from comment #18)
> I saw that this bug changed status to RESOLVED, but I'm still experience
> issues. I can't for example not sync Merge Windows
> (https://addons.mozilla.org/en-US/firefox/addon/merge-window/) and Emoji Box
> (https://addons.mozilla.org/en-US/firefox/addon/emoji-box/).

What version of Firefox are you using? The fix will not hit the release channel until later this week.
Flags: needinfo?(johan.bjornehall)
Latest Firefox Nightly.
Flags: needinfo?(johan.bjornehall)
Can you please ensure you have Trace level logging (using the about:sync addon is probably the easiest way to achieve that), then reproduce the problem (eg, change the enabled state of the addon and sync), then upload the logs?
Flags: needinfo?(johan.bjornehall)
Somehow I did not have the latest version after all, so after updating to the latest version, the issue went away. Thank you!
Flags: needinfo?(johan.bjornehall)
Thanks for following up, kartongsaft!
Status: REOPENED → RESOLVED
Closed: 11 months ago10 months ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.