IMAP sub-subfolders not shown when springloaded folder opens

RESOLVED DUPLICATE of bug 138759

Status

()

RESOLVED DUPLICATE of bug 138759
17 years ago
10 years ago

People

(Reporter: ewv, Assigned: hewitt)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
Dragging a message in Mail/News to an IMAP folder opens that folder and I can
drop it in any of its sub-folders, but sub-folders with sub-folders are not
shown and cannot be opened. Clicking on the twisty normally shows these folders.

In other words, if I have an IMAP hierarchy that looks like:

Plants
Animals
  -Mammals
    -Dogs
    -Cats
  -Fish

I can't using drag and drop with spring loaded folders put anything in the Dogs
or Cats folder. I can only get down to Mammals and Fish.

Not sure at all if this is the right component. If this is a problem with IMAP
or spring loaded folders in general.

Comment 1

16 years ago
Springloaded folder doesn't work at all under MacOS 8.6

Mozilla 1.0.0+
Mozilla/5.0 (Macintosh; U; PPC; en-US; rv:1.0.0+) Gecko/20020603

This is a 4xp feature.
WFM with trunk 2002073022, linux. reporter (Eric Vaandering): can you reproduce
this bug with a recent build of mozilla (for example, 1.1beta)? if so, please
comment again with details. if not, please resolve this bug as WORKSFORME. thanks.
no answer.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 4

16 years ago
Nope, just had this problem with 1.1 on linux. Reopening. The little triangle
which shows there is something to be opened doesn't exist and hovering over the
folder won't open it.
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---

Comment 5

16 years ago
WFM on linux

Comment 6

16 years ago
I know that this was already closed and then reopened again, could you try again
with latest builds and possibly provide more exact steps to reproduce it ?
I don't want to close this onw w/o asking.

Comment 7

16 years ago
Hi,

I just experienced that the problem still exists in the actual release V1.3
(based on Gecko/20030312; downloaded March 14th).

But: the problem only appears if you started your mail client and you did not
open one of the folders containing subfolders before testing!

If you first open the subfolders and then close them again, it is possible to
drag emails into subfolders. I think the folder hierarchy information is cached
if you once opened one of the folders.

--------------------

A related problem is now fixed in V1.3: it is now possible to move emails in
folders containing subfolders using the "File" button in the menu. This was not
possible with older versions (1.2.1 or so).

Best regards,
Roland.

Comment 8

16 years ago
Amendment to my last comment: Subfolders contained in Folders are also not
visible in the "File" menu dialog before having opened the folder at least once
manually. I think this behaviour is related to the "drag and drop" problem...

Roland.

Comment 9

15 years ago
Reporter can you reproduce this bug with a newer build (1.4 final)?
If not, then please close this bug as worksforme. Thanks.

Comment 10

15 years ago
The bug still exists in V 1.4 final!

Dragging and dropping a message in a subfolder of a subfolder only exists if you
have opened the fist level of subfolder at least once manually by clicking on
the little rectangle: this reads the tree stucture and once read it's available
also for drag and drop. If you didn't read the tree structure before manually,
only the first level of subfolders is visible.

Roland.

Comment 11

15 years ago
Isn't this a duplicate of bug #138759 ??

Comment 12

15 years ago

*** This bug has been marked as a duplicate of 138759 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago15 years ago
Resolution: --- → DUPLICATE

Updated

10 years ago
Component: XP Toolkit/Widgets: Trees → XUL
QA Contact: shrir → xptoolkit.widgets
You need to log in before you can comment on or make changes to this bug.