Closed Bug 1468063 Opened 3 years ago Closed 3 years ago

Unable to save several media files at once in Page Info

Categories

(SeaMonkey :: Page Info, defect)

SeaMonkey 2.57 Branch
defect
Not set
normal

Tracking

(seamonkey2.57esr fixed, seamonkey2.58 wontfix, seamonkey2.59 fixed)

RESOLVED FIXED
seamonkey2.59
Tracking Status
seamonkey2.57esr --- fixed
seamonkey2.58 --- wontfix
seamonkey2.59 --- fixed

People

(Reporter: frg, Assigned: frg)

References

Details

Attachments

(1 file, 1 obsolete file)

+++ This bug was initially created as a clone of Bug #796994 +++

Bug 796994 introduced an error in Page Info. You are only able to save one media file at a time. If you select more than one file and try to save them into a folder a undefined rowArray will be logged in console. Probably during a rebase in development some lines got lost.
Attached patch 1468063-pageinfo.patch (obsolete) — Splinter Review
[Approval Request Comment]
Regression caused by (bug #): 796994
User impact if declined: broken functionality
Testing completed (on m-c, etc.): c-r 2.53
Risk to taking this patch (and alternatives if risky): none already broken.
String changes made by this patch: --
Attachment #8984728 - Flags: review?(iann_bugzilla)
Attachment #8984728 - Flags: approval-comm-esr60?
Comment on attachment 8984728 [details] [diff] [review]
1468063-pageinfo.patch

>-  var count = tree.view.selection.count;
>-  if (count == 1) {
>-    var item = getSelectedImage(tree);
>+  var rowArray = getSelectedRows(tree);
>+  if (rowArray.length == 1) {
>+    let row = rowArray[0];
>+    let item = gImageView.data[row][COL_IMAGE_NODE]; 
>     var url = gImageView.data[tree.currentIndex][COL_IMAGE_ADDRESS];
Shouldn't this be data[row] as well?
Yes should be row. It worked but if you steal code you should steal everything :) Thanks for catching it.
Attachment #8984728 - Attachment is obsolete: true
Attachment #8984728 - Flags: review?(iann_bugzilla)
Attachment #8984728 - Flags: approval-comm-esr60?
Attachment #8984743 - Flags: review?(iann_bugzilla)
Attachment #8984743 - Flags: approval-comm-esr60?
I also introduced a traing blank. Will fix it either in the next round or during checkin.
Comment on attachment 8984743 [details] [diff] [review]
1468063-pageinfo-V2.patch

LGTM r/a=me
Attachment #8984743 - Flags: review?(iann_bugzilla)
Attachment #8984743 - Flags: review+
Attachment #8984743 - Flags: approval-comm-esr60?
Attachment #8984743 - Flags: approval-comm-esr60+
Component: General → Page Info
Pushed by frgrahl@gmx.net:
https://hg.mozilla.org/comm-central/rev/f19420b1c733
Fix undefined rowArray when trying to saving more than one media file in Page Info. r=IanN
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.