Closed Bug 1468129 Opened Last year Closed Last year

Crash in RtlRaiseStatus | RtlVirtualUnwind | RtlVirtualUnwindStub | static void WalkStackMain64

Categories

(Core :: mozglue, defect, critical)

Unspecified
Windows 10
defect
Not set
critical

Tracking

()

RESOLVED WONTFIX
Tracking Status
firefox-esr52 --- unaffected
firefox-esr60 --- unaffected
firefox60 --- unaffected
firefox61 --- unaffected
firefox62 --- fix-optional

People

(Reporter: calixte, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: crash, regression)

Crash Data

This bug was filed from the Socorro interface and is
report bp-6422796b-41ab-4da6-a94e-3d0620180609.
=============================================================

Top 10 frames of crashing thread:

0 ntdll.dll RtlRaiseStatus 
1 ntdll.dll RtlVirtualUnwind 
2 kernel32.dll RtlVirtualUnwindStub 
3 mozglue.dll static void WalkStackMain64 mozglue/misc/StackWalk.cpp:320
4 mozglue.dll MozStackWalkThread mozglue/misc/StackWalk.cpp:441
5 xul.dll static void DoMozStackWalkBacktrace tools/profiler/core/platform.cpp:1122
6 xul.dll static void Sampler::SuspendAndSampleAndResumeThread<<lambda_9998a5e560acb364e76945bccdc5e530> > tools/profiler/core/platform-win32.cpp:177
7 xul.dll profiler_suspend_and_sample_thread tools/profiler/core/platform.cpp:3661
8 xul.dll mozilla::ThreadStackHelper::GetStack toolkit/components/backgroundhangmonitor/ThreadStackHelper.cpp:141
9 xul.dll mozilla::BackgroundHangManager::RunMonitorThread toolkit/components/backgroundhangmonitor/BackgroundHangMonitor.cpp:385

=============================================================

There is 1 crash in nightly 62 with buildid 20180608220136. In analyzing the backtrace, the regression may have been introduced by patch [1] to fix bug 1452204.

[1] https://hg.mozilla.org/mozilla-central/rev?node=12b8065ee9fc
Flags: needinfo?(xidorn+moz)
EXCEPTION_BAD_FUNCTION_TABLE? I cannot even find any information related to how this can happen...
Flags: needinfo?(xidorn+moz)
Just 1 crash in 5 days. Let's see if there's any uptick in the next week, otherwise this feels fix-optional.
(In reply to Mike Taylor [:miketaylr] (62 Regression Engineering Owner) from comment #2)
> Just 1 crash in 5 days. Let's see if there's any uptick in the next week,
> otherwise this feels fix-optional.

Looks as if there hasn't been any further crashes since the one using 20180608220136.
Closing because no crash reported since 12 weeks.
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.