Closed Bug 1468309 Opened Last year Closed Last year

Special folder in Library right side pane will not open by double click

Categories

(Firefox :: Bookmarks & History, defect, P2)

60 Branch
x86_64
Windows 10
defect

Tracking

()

RESOLVED FIXED
Firefox 62
Tracking Status
firefox-esr52 --- unaffected
firefox-esr60 --- wontfix
firefox60 --- wontfix
firefox61 --- wontfix
firefox62 + fixed

People

(Reporter: alice0775, Assigned: standard8)

References

Details

(Keywords: regression)

Attachments

(1 file)

[Tracking Requested - why for this release]:

Reproducible: always

Steps To Reproduce:
1. Open "Show All Bookmarks"
2. Click "ALL Bookmarks" folder in Left side pane
3. Click "Bookmarks Toolbar", "Bookmarks Menu" and "Other Bookmarks" ij the right side pane


Actual Results:
Nothing happens

Expected Results
Bookmark list should appear in the right side pane
Version: 62 Branch → 60 Branch
Please can you include any output from the browser console window, when you're opening the library & selecting the folders.

Also, taking a copy of places.sqlite, then running the Verify Integrity option in about:support might also help with resolving the issue.
Flags: needinfo?(alice0775)
(In reply to Mark Banner (:standard8) from comment #1)
> Please can you include any output from the browser console window, when
> you're opening the library & selecting the folders.
> 

no error is shown in Browser console.

> 
> Also, taking a copy of places.sqlite, then running the Verify Integrity
> option in about:support might also help with resolving the issue.

This problem occurs with clean new profile.
Flags: needinfo?(alice0775)
typo in comment #0.
s/ij/in/
Works for me with existing and clean profiles on Mac FF 60.0.2, 61.0b12 and 62.0a1 (latest nightly), and also on Windows 10 FF 66.0.2.

Note that other bookmarks is empty for new profiles, but Toolbar & Menu should have the default bookmarks in them.

Maybe see if there's any warnings in the browser console just after startup?
Status: NEW → UNCONFIRMED
Ever confirmed: false
(In reply to Mark Banner (:standard8) from comment #4)
> Works for me with existing and clean profiles on Mac FF 60.0.2, 61.0b12 and
> 62.0a1 (latest nightly), and also on Windows 10 FF 66.0.2.

Just confirm, 
Did you click on a special folder IN THE RIGHT SIDE PANE(SEE STR STEP3)?


> 
> Note that other bookmarks is empty for new profiles, but Toolbar & Menu
> should have the default bookmarks in them.

I know that.

> 
> Maybe see if there's any warnings in the browser console just after startup?


Browser console just after Nightly62.0a1 started.

Bootstrapped manifest not allowed to use 'resource' directive. chrome.manifest:1
Bootstrapped manifest not allowed to use 'resource' directive. chrome.manifest:7
Bootstrapped manifest not allowed to use 'resource' directive. chrome.manifest:2
Content Security Policy: Directive ‘child-src’ has been deprecated. Please use directive ‘worker-src’ to control workers, or directive ‘frame-src’ to control frames respectively. 


WHY UNCONFIRMED?
I can reproduce the issue 100%:
And Regression window points to
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=12de5643ae0ae6ad6a97797f2a07fe856f9b66e1&tochange=c388570c330fd7745f12eca3258cc3ae4b3d5bb2

I have confidence 100% this is a regression.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: steps-wanted
> 3. Click "Bookmarks Toolbar", "Bookmarks Menu" and "Other Bookmarks" ij the right side pane

Sorry

s/Click/Double click/
(In reply to Alice0775 White from comment #5)
> (In reply to Mark Banner (:standard8) from comment #4)
> Just confirm, 
> Did you click on a special folder IN THE RIGHT SIDE PANE(SEE STR STEP3)?

Sorry, I'd missed the right-side pane part, and only having "click" rather than "double click" didn't help.

> WHY UNCONFIRMED?

At the time, I couldn't reproduce on any version, so unconfirmed is generally the better state in that case and reflects what was understood at the time.
Keywords: qawanted
Summary: Special folder in Library right side pane would not open by click → Special folder in Library right side pane will not open by double click
Assignee: nobody → standard8
Status: NEW → ASSIGNED
Component: Places → Bookmarks & History
Priority: -- → P2
Product: Toolkit → Firefox
Comment on attachment 8985030 [details]
Bug 1468309 - Fix double clicking on a special folder on right side pane on the bookmarks library view.

Marco Bonardo [::mak] has approved the revision.

https://phabricator.services.mozilla.com/D1637
Attachment #8985030 - Flags: review+
Pushed by mbanner@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/9bcaafb846a7
Fix double clicking on a special folder on right side pane on the bookmarks library view. r=mak
https://hg.mozilla.org/mozilla-central/rev/9bcaafb846a7
Status: ASSIGNED → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → Firefox 62
This feels like something that can ride the trains, but feel free to nominate for backport if you feel strongly otherwise.
(In reply to Ryan VanderMeulen [:RyanVM] from comment #12)
> This feels like something that can ride the trains, but feel free to
> nominate for backport if you feel strongly otherwise.

Agreed, there's an easy work around and I suspect most people use the left-pane route anyway.
You need to log in before you can comment on or make changes to this bug.