Closed Bug 14684 Opened 21 years ago Closed 21 years ago

Need to automatically update mozregistry.dat

Categories

(Core Graveyard :: Profile: BackEnd, defect, P3, major)

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 16209

People

(Reporter: selmer, Assigned: racham)

References

Details

Seth's change that requires people to delete their mozregistry needs to be
handled in the beta automatically.  It's too much to expect that everyone will
know and remember this step since we weren't able to do it even internally very
well.

The profile manager needs to put a version string inside the mozregistry.dat
file and compare against that version.  If it's not there or it's too old, then
some action must be taken to bring the registry back up to current.

In the case of this change, the best thing would be to read in the old values,
convert them, then write them out again.
Status: NEW → ASSIGNED
Target Milestone: M12
Blocks: 12696
Status: ASSIGNED → RESOLVED
Closed: 21 years ago
Resolution: --- → DUPLICATE
Marking this dup of bug# 16209.
A version string will be added to the registry.
On identifying the older versions, all the old
paths will be chnaged to current format.

*** This bug has been marked as a duplicate of 16209 ***
Status: RESOLVED → VERIFIED
Component: Profile Manager → Profile Manager BackEnd
Moving all Profile Manager bugs to new Profile Manager Backend component.
Profile Manager component to be deleted.
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.