Closed Bug 1468534 Opened 4 years ago Closed 3 years ago

Crash in static void core::option::expect_failed | struct style::gecko_bindings::sugar::ownership::Strong<T> geckoservo::glue::Servo_ResolveStyle

Categories

(Core :: CSS Parsing and Computation, defect, P2)

61 Branch
All
Windows
defect

Tracking

()

RESOLVED WORKSFORME
Tracking Status
firefox-esr52 --- unaffected
firefox-esr60 --- unaffected
firefox60 --- unaffected
firefox61 + wontfix
firefox62 + wontfix
firefox63 --- affected

People

(Reporter: philipp, Assigned: emilio)

References

Details

(Keywords: crash, regression)

Crash Data

This bug was filed from the Socorro interface and is
report bp-94c9fda0-2c67-4a64-989d-567030180606.
=============================================================

Top 10 frames of crashing thread:

0 xul.dll static void std::panicking::rust_panic_with_hook src/libstd/panicking.rs:583
1 xul.dll static void std::panicking::begin_panic<alloc::string::String> src/libstd/panicking.rs:538
2 xul.dll static void std::panicking::begin_panic_fmt src/libstd/panicking.rs:522
3 xul.dll static void core::panicking::panic_fmt src/libcore/panicking.rs:71
4 xul.dll static void core::option::expect_failed src/libcore/option.rs:891
5 xul.dll struct style::gecko_bindings::sugar::ownership::Strong<style::gecko_properties::ComputedValues> geckoservo::glue::Servo_ResolveStyle servo/ports/geckolib/glue.rs:4281
6 xul.dll nsCSSFrameConstructor::ResolveComputedStyle layout/base/nsCSSFrameConstructor.cpp:4961
7 xul.dll nsCSSFrameConstructor::AddFrameConstructionItems layout/base/nsCSSFrameConstructor.cpp:5543
8 xul.dll nsCSSFrameConstructor::ProcessChildren layout/base/nsCSSFrameConstructor.cpp:10293
9 xul.dll nsCSSFrameConstructor::ConstructFrameFromItemInternal layout/base/nsCSSFrameConstructor.cpp:4037

=============================================================

this crash signature is newly appearing in fiefox 61. a number of comments are saying the crash occurred when people tried to access the downloads panel.
It sounds really critical, especially given that it happens in chrome process for download panel, but without a reliable STR, it's probably not going to be very actionable :/
Priority: -- → P1
Depends on: 1469076
Priority: P1 → P2
Emilio - Does your fix for bug 1468534 fix this one?  If not, is this bug actionable or not?  If it's not actionable, can you needinfo me back?  Thanks!
Assignee: nobody → emilio
Flags: needinfo?(emilio)
I'm not completely sure it does, but it's worth a shot, I guess we need to monitor the crash rate.

I don't think this is actionable if it does not, without any STR.
Flags: needinfo?(emilio) → needinfo?(mreavy)
I'm leaving this needinfo to me on purpose so I remember to come back to this.  And the bug I meant to mention in Comment 2 was Bug 1469076.
This is fairly low volume in 61 and 62, and it's hard to tell if it's fixed in 63 nightly. 
Marking fix-optional for 62, but if we come up with STR or a patch I'm happy to try to get a fix into 62 before release.
Flags: needinfo?(mreavy)
Looks like this is still lingering around with low volume on 62/63.
No crash since August 27, either it was fixed in another bug or the signature has changed, emilio, what do you think?
Flags: needinfo?(emilio)
Given the dates it was likely bug 1482694.
Status: NEW → RESOLVED
Closed: 3 years ago
Flags: needinfo?(emilio)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.