Closed Bug 1468666 Opened 3 years ago Closed 3 years ago

Reattaching detached tab break tabId information

Categories

(WebExtensions :: Frontend, defect)

60 Branch
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1443221

People

(Reporter: u608644, Unassigned)

Details

Attachments

(1 file)

background.js:
browser.tabs.onUpdated.addListener(...){console.log(tabInformation);}
browser.webNavigation.onCompleted.addListener(()=>{browser.tabs.query({active:true,currentWindow:true}).then(console.log(tabInformation)};

Latest Firefox ESR doesn't have this bug.

1. Open new Firefox with add-on installed.
1a. Also open "Browser Console".
2. Open 3 tabs. (Window A have 3 empty tabs: [tab1][tab2][tab3])
3. Select [tab3] and press F5 to reload it.
4. Drag [tab3] to other place. This will open [tab3] as a new Window.
5. Simply drag [tab3] tab to Window A. This will merge [tab3] to Window A. [tab1][tab2][tab3]
6. So the [tab3] is currently active, press [F5] to reload.
7. Take a look at browser console.

Actual result:
tabId become different.

Before detach:
[tab1][tab2][tab3:id=28]

After reattach
[tab1][tab2][tab3:id=28,id=42]

Again, ESR version never have this behavior.
Component: Tabbed Browser → Frontend
Product: Firefox → WebExtensions
This issue sounds pretty similar to Bug 1443221, which has a fixed landed in Firefox 61 (which is not in Firefox 60), 
are you still able to trigger the issue in a Firefox version >= 61?

(I just tried on both Firefox 60 and a recent Nightly version and I'm able to trigger it on 60 but not on Nightly, but I also want to be sure that I'm triggering the exact same issue, I'm going to attach to this issue the minimal test extension that I used locally).
I'm closing this as a duplicate of Bug 1443221 because, as described in Comment 1, this seems to be exactly the same bug that Bug 1443221 has fixed in Firefox 61.

Nevertheless, feel free to re-open it if you are still able to reproduce it on Firefox 61.
Status: UNCONFIRMED → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1443221
You need to log in before you can comment on or make changes to this bug.