2.21 - 3.08% build times (linux64) regression on push 8a278eebbe5df459eab42bc7f1f515cbc8e38a01 (Sat Jun 9 2018)

RESOLVED FIXED in Firefox 62

Status

RESOLVED FIXED
7 months ago
7 months ago

People

(Reporter: igoldan, Assigned: scarrillo)

Tracking

(Blocks: 1 bug, {regression})

unspecified
mozilla62
Unspecified
Linux
regression
Dependency tree / graph

Firefox Tracking Flags

(firefox-esr52 unaffected, firefox-esr60 unaffected, firefox60 unaffected, firefox61 unaffected, firefox62 fixed)

Details

Attachments

(1 attachment)

We have detected a build metrics regression from push:

https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=8ca33f3d833974f81ea8e744b4ddfc2a811f8d8c&tochange=c77f7fe4c21b50dc7525602f9b147530e89c2e8b

As author of one of the patches included in that push, we need your help to address this regression.

Regressions:

  3%  build times linux64 opt taskcluster-c4.4xlarge tup     1,100.16 -> 1,134.02
  2%  build times linux64 opt plain taskcluster-c4.4xlarge   2,057.16 -> 2,102.68


You can find links to graphs and comparison views for each of the above tests at: https://treeherder.mozilla.org/perf.html#/alerts?id=13765

On the page above you can see an alert for each affected platform as well as a link to a graph showing the history of scores for this test. There is also a link to a treeherder page showing the jobs in a pushlog format.

To learn more about the regressing test(s), please see: https://developer.mozilla.org/en-US/docs/Mozilla/Performance/Automated_Performance_Testing_and_Sheriffing/Build_Metrics
Component: General → General
Product: Testing → Firefox Build System
Version: 62 Branch → unspecified
Flags: needinfo?(scarrillo)
Bug 1464235 seems the one related to this regression. If I got this wrong, please let me know. Some how, the performance results don't show up per changeset, even though I backfilled them several times from Treeherder.
The tup build is expected to regress from bug 1464235 since zipping and uploading the tup database takes a decent amount of time. However, chmanchester mentioned that we should only be uploading that artifact on demand rather than on every push. :scarrillo will add a patch to fix that.

From the graph, the linux64 plain build looks like it was just a spurious incident and not a regression. Future builds were back down to the original range. I don't think bug 1464235 should've affected those builds anyway, since it's specific to the tup build.
Flags: needinfo?(scarrillo)
Comment hidden (mozreview-request)
(Assignee)

Updated

7 months ago
Attachment #8986029 - Flags: review?(mshal)

Comment 4

7 months ago
mozreview-review
Comment on attachment 8986029 [details]
Bug 1468688 - default to upload tub db is false

https://reviewboard.mozilla.org/r/251488/#review257780

Looks good - thanks!
Attachment #8986029 - Flags: review?(mshal) → review+
Assignee: nobody → scarrillo

Comment 5

7 months ago
Pushed by mshal@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/9c8e2b62ae58
default to upload tub db is false r=mshal

Comment 6

7 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/9c8e2b62ae58
Status: NEW → RESOLVED
Last Resolved: 7 months ago
status-firefox62: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla62
status-firefox60: --- → unaffected
status-firefox61: --- → unaffected
status-firefox-esr52: --- → unaffected
status-firefox-esr60: --- → unaffected
You need to log in before you can comment on or make changes to this bug.