Unexpected lack of isolation in private mode [design flaw]

RESOLVED DUPLICATE of bug 117222

Status

()

defect
RESOLVED DUPLICATE of bug 117222
Last year
Last year

People

(Reporter: jonas, Unassigned)

Tracking

61 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:61.0) Gecko/20100101 Firefox/61.0
Build ID: 20180611134439

Steps to reproduce:

1. Open multiple private mode windows, log in to the same service in both with different accounts


Actual results:

I discovered there is a quite unexpected lack of isolation in private mode when opening multiple private windows. I highly expected them to be separate to each other with cookies, sessions,... and they just aren't.

This is both rather inconvenient (can't use it to log in to multiple places, which is the main use of private mode for me) and dangerous if people are not aware. I think this should be changed.


Expected results:

Separate private mode windows are separate in context
(In reply to jonas from comment #0)
> can't use it to log in to multiple places

That's what container tabs are for, though they're not private. It's a built-in feature in Firefox 62 and an extension for other versions.
https://support.mozilla.org/kb/containers
Status: UNCONFIRMED → RESOLVED
Closed: Last year
Component: Untriaged → Private Browsing
OS: Unspecified → All
Hardware: Unspecified → All
Resolution: --- → DUPLICATE
Duplicate of bug: sessionperwindow
I suggest this is a quite separate issue, because IMHO this is a basic UI problem. "New private window" simply suggests to me that it opens a NEW private context, and it just doesn't (it opens or reuses a single private context which I find super non-intuitive). I'm not sure if the best way is to change the UI or the functionality, but the point is that I think private mode as it is, has a central design issue.

The one you duplicated against is simply a feature request which could or could not provide what I expected, but it doesn't really talk about private mode UI. (seems more of a general discussion of having this somewhere or not)

As for containers, as you pointed out yourself they are not really comparable because they are not private.
(In reply to jonas from comment #2)
> I suggest this is a quite separate issue

Bug 117222 is the catch-all bug for separate private browsing contexts. Go have a look at its list of duplicates.

> IMHO this is a basic UI problem. "New private window" simply suggests to me
> that it opens a NEW private context

It opens a new window, which is private. I don't think it suggests separate contexts any more than the "New Window" and "New Tab" menu items. I see no way to improve the wording, though if you have any specific suggestions, feel free to make them.
> It opens a new window, which is private. I don't think it suggests separate contexts any more than the "New Window" and "New Tab" menu items. 

I think it does, and on the other bug, a recent commenter seems to agree with me. But I'm not sure how to best fix it in the UI (which probably suggests they should be separate in context - but a more widespread user poll might be the best way to advance and find out how it should behave most intuitively).

> Bug 117222 is the catch-all bug for separate private browsing contexts.

Ok. I mean it's up to you really, I don't want to manage Mozilla's bugs. But it seems to me the other bug is way more muddied and about making this happen in all sorts of other places like regular new window, which I think isn't necessarily a good idea (and probably never gonna happen anyway). However, for the private mode IMHO it's an entirely different story. Therefore, I would suggest having a tracking bug for that is not a bad idea. But really up to you.

Thanks for triaging! I'll wait and see where this goes
You need to log in before you can comment on or make changes to this bug.