Closed Bug 14694 Opened 20 years ago Closed 20 years ago

Mouseover in page causes whitespace to appear

Categories

(Core :: Layout, defect, P3)

x86
Linux
defect

Tracking

()

VERIFIED FIXED

People

(Reporter: alecf, Assigned: rods)

References

()

Details

(Whiteboard: Fixed in my tree)

Attachments

(1 file)

When I mouse over the first link (Vehicles) on this page, a giant bunch of
whitespace appears (vertically) between the form (with "show only ads with
photos") and the directory, and pushes the whole directory down about 2 inches
on the page.
Status: NEW → ASSIGNED
Looking at it closer, there's no :hover or other stylr rules on the links. It
turns out it's the gfx rendered buttons and combo box. When the mouse moves over
one of them, an incremental reflow command is generated and for some reason that
causes the table to reflow incorrectly
*** Bug 14730 has been marked as a duplicate of this bug. ***
The problem is with the combo box control, which is returning an invalid max
element height.

I'm attaching a small example that demonstrates the problem. Notice the warnings
output to the console when loading
Assignee: troy → kmcclusk
Status: ASSIGNED → NEW
Kevin, the problem is that the combobox code isn't correctly computing the max
element size.
Assignee: kmcclusk → rods
Rod, I think you already have a fix for this
Status: NEW → ASSIGNED
Whiteboard: Fixed in my tree
I have this fixed in my tree.
Was not sending back the proper maxElementsize - Fixed
Status: ASSIGNED → RESOLVED
Closed: 20 years ago
Resolution: --- → FIXED
Status: RESOLVED → VERIFIED
Fixed in the Oct 1 build.
You need to log in before you can comment on or make changes to this bug.