Closed Bug 1469416 Opened 2 years ago Closed 2 years ago

Assertion failure: data == GetDisplayItemData(aFrame, aDisplayItemKey), at src/layout/painting/FrameLayerBuilder.cpp:2264

Categories

(Core :: Web Painting, defect, P1)

defect

Tracking

()

RESOLVED DUPLICATE of bug 1468738
Tracking Status
firefox62 --- affected

People

(Reporter: tsmith, Assigned: jnicol)

References

(Blocks 1 open bug)

Details

(Keywords: assertion, testcase)

Attachments

(1 file)

Attached file testcase.html
Reduced with m-c:
BuildID=20180618155100
SourceStamp=97eb512f532b933d8b5b72f160815e0727229890

Assertion failure: data == GetDisplayItemData(aFrame, aDisplayItemKey), at src/layout/painting/FrameLayerBuilder.cpp:2264

#0 mozilla::FrameLayerBuilder::GetOldLayerForFrame(nsIFrame*, unsigned int, mozilla::DisplayItemData*) src/layout/painting/FrameLayerBuilder.cpp:2264:3
#1 mozilla::PaintedLayerData::Accumulate(mozilla::ContainerState*, nsDisplayItem*, mozilla::gfx::IntRectTyped<mozilla::gfx::UnknownUnits> const&, nsRect const&, mozilla::DisplayItemClip const&, mozilla::LayerState, nsDisplayList*, mozilla::DisplayItemEntryType) src/layout/painting/FrameLayerBuilder.cpp:3673:28
#2 mozilla::ContainerState::ProcessDisplayItems(nsDisplayList*) src/layout/painting/FrameLayerBuilder.cpp:4783:27
#3 mozilla::FrameLayerBuilder::BuildContainerLayerFor(nsDisplayListBuilder*, mozilla::layers::LayerManager*, nsIFrame*, nsDisplayItem*, nsDisplayList*, mozilla::ContainerLayerParameters const&, mozilla::gfx::Matrix4x4Typed<mozilla::gfx::UnknownUnits, mozilla::gfx::UnknownUnits> const*, unsigned int) src/layout/painting/FrameLayerBuilder.cpp:5920:9
#4 nsDisplayList::BuildLayers(nsDisplayListBuilder*, mozilla::layers::LayerManager*, unsigned int, bool) src/layout/painting/nsDisplayList.cpp:2529:9
#5 nsDisplayList::PaintRoot(nsDisplayListBuilder*, gfxContext*, unsigned int) src/layout/painting/nsDisplayList.cpp:2740:20
#6 nsLayoutUtils::PaintFrame(gfxContext*, nsIFrame*, nsRegion const&, unsigned int, nsDisplayListBuilderMode, nsLayoutUtils::PaintFrameFlags) src/layout/base/nsLayoutUtils.cpp:3832:12
#7 mozilla::PresShell::Paint(nsView*, nsRegion const&, unsigned int) src/layout/base/PresShell.cpp:6314:5
#8 nsViewManager::ProcessPendingUpdatesPaint(nsIWidget*) src/view/nsViewManager.cpp:480:19
#9 nsViewManager::ProcessPendingUpdatesForView(nsView*, bool) src/view/nsViewManager.cpp:412:33
#10 nsViewManager::ProcessPendingUpdates() src/view/nsViewManager.cpp:1102:5
#11 nsRefreshDriver::Tick(long, mozilla::TimeStamp) src/layout/base/nsRefreshDriver.cpp:2039:11
#12 mozilla::RefreshDriverTimer::TickRefreshDrivers(long, mozilla::TimeStamp, nsTArray<RefPtr<nsRefreshDriver> >&) src/layout/base/nsRefreshDriver.cpp:301:7
#13 mozilla::RefreshDriverTimer::Tick(long, mozilla::TimeStamp) src/layout/base/nsRefreshDriver.cpp:320:5
#14 mozilla::VsyncRefreshDriverTimer::RunRefreshDrivers(mozilla::TimeStamp) src/layout/base/nsRefreshDriver.cpp:760:5
#15 mozilla::VsyncRefreshDriverTimer::RefreshDriverVsyncObserver::TickRefreshDriver(mozilla::TimeStamp) src/layout/base/nsRefreshDriver.cpp:673:35
#16 mozilla::VsyncRefreshDriverTimer::RefreshDriverVsyncObserver::NotifyVsync(mozilla::TimeStamp) src/layout/base/nsRefreshDriver.cpp:574:9
#17 mozilla::layout::VsyncChild::RecvNotify(mozilla::TimeStamp const&) src/layout/ipc/VsyncChild.cpp:68:16
#18 mozilla::layout::PVsyncChild::OnMessageReceived(IPC::Message const&) src/obj-firefox/ipc/ipdl/PVsyncChild.cpp:167:20
#19 mozilla::ipc::PBackgroundChild::OnMessageReceived(IPC::Message const&) src/obj-firefox/ipc/ipdl/PBackgroundChild.cpp:1988:28
#20 mozilla::ipc::MessageChannel::DispatchAsyncMessage(IPC::Message const&) src/ipc/glue/MessageChannel.cpp:2134:25
#21 mozilla::ipc::MessageChannel::DispatchMessage(IPC::Message&&) src/ipc/glue/MessageChannel.cpp:2064:17
#22 mozilla::ipc::MessageChannel::RunMessage(mozilla::ipc::MessageChannel::MessageTask&) src/ipc/glue/MessageChannel.cpp:1910:5
#23 mozilla::ipc::MessageChannel::MessageTask::Run() src/ipc/glue/MessageChannel.cpp:1943:15
#24 nsThread::ProcessNextEvent(bool, bool*) src/xpcom/threads/nsThread.cpp:1059:14
#25 NS_ProcessNextEvent(nsIThread*, bool) src/xpcom/threads/nsThreadUtils.cpp:519:10
#26 mozilla::ipc::MessagePump::Run(base::MessagePump::Delegate*) src/ipc/glue/MessagePump.cpp:125:5
#27 MessageLoop::RunInternal() src/ipc/chromium/src/base/message_loop.cc:325:10
#28 MessageLoop::Run() src/ipc/chromium/src/base/message_loop.cc:298:3
#29 nsBaseAppShell::Run() src/widget/nsBaseAppShell.cpp:157:27
#30 XRE_RunAppShell() src/toolkit/xre/nsEmbedFunctions.cpp:896:22
#31 mozilla::ipc::MessagePumpForChildProcess::Run(base::MessagePump::Delegate*) src/ipc/glue/MessagePump.cpp:269:9
#32 MessageLoop::RunInternal() src/ipc/chromium/src/base/message_loop.cc:325:10
#33 MessageLoop::Run() src/ipc/chromium/src/base/message_loop.cc:298:3
#34 XRE_InitChildProcess(int, char**, XREChildData const*) src/toolkit/xre/nsEmbedFunctions.cpp:722:34
#35 content_process_main(mozilla::Bootstrap*, int, char**) src/browser/app/../../ipc/contentproc/plugin-container.cpp:50:30
#36 main src/browser/app/nsBrowserApp.cpp:287:18
#37 __libc_start_main /build/glibc-Cl5G7W/glibc-2.23/csu/../csu/libc-start.c:291
#38 _start (firefox+0x4236e4)
Flags: in-testsuite?
This might be a debug crash similar to bug 1468738.
Assignee: nobody → jnicol
Priority: -- → P1
I can't reproduce this any more, looks like it was fixed with bug 1468738.
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1468738
See Also: → 1567274
You need to log in before you can comment on or make changes to this bug.