Closed Bug 1469766 Opened Last year Closed Last year

Update OOM hook on rustc 1.28 after rust PR 51543

Categories

(Toolkit :: Crash Reporting, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla62
Tracking Status
firefox62 --- fixed

People

(Reporter: glandium, Assigned: glandium)

References

Details

Attachments

(1 file)

No description provided.
Comment on attachment 8986371 [details]
Bug 1469766 - Update OOM hook on rustc 1.28 after rust PR 51543.

https://reviewboard.mozilla.org/r/251744/#review258178
Attachment #8986371 - Flags: review?(nfroyd) → review+
Pushed by mh@glandium.org:
https://hg.mozilla.org/integration/autoland/rev/11018f20ca8d
Update OOM hook on rustc 1.28 after rust PR 51543. r=froydnj
Comment on attachment 8986371 [details]
Bug 1469766 - Update OOM hook on rustc 1.28 after rust PR 51543.

Approval Request Comment
[Feature/Bug causing the regression]: bug 1465709
[User impact if declined]: Build failure with rust 1.28
[Is this code covered by automated tests?]: Kind of, the tup builds are building with latest rust 1.28 nightly.
[Has the fix been verified in Nightly?]: N/A
[Needs manual test from QE? If yes, steps to reproduce]: N/A
[List of other uplifts needed for the feature/fix]: N/A
[Is the change risky?]: No
[Why is the change risky/not risky?]: It changes API calls to fit last minute changes in rust 1.28. For mozilla.org builds, this is actually NPOTB because 62 is built with 1.24.
[String changes made/needed]: N/A
Attachment #8986371 - Flags: approval-mozilla-beta?
Comment on attachment 8986371 [details]
Bug 1469766 - Update OOM hook on rustc 1.28 after rust PR 51543.

IIUC, this bug only affects 62, which is still being kept in sync between m-c and m-b until the version bump on Monday. So no need to uplift :)
Attachment #8986371 - Flags: approval-mozilla-beta? → approval-mozilla-beta-
https://hg.mozilla.org/mozilla-central/rev/11018f20ca8d
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → mozilla62
You need to log in before you can comment on or make changes to this bug.