Closed Bug 1469827 Opened 3 years ago Closed 3 years ago

The etiquette check on "Create new a Bugzilla account" lacks a proper label

Categories

(bugzilla.mozilla.org :: Extensions, defect)

Production
defect
Not set
normal

Tracking

()

RESOLVED FIXED

People

(Reporter: joerg, Assigned: joerg)

Details

(Keywords: access, good-first-bug)

Attachments

(1 file)

45 bytes, text/x-github-pull-request
Details | Review
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:60.0) Gecko/20100101 Firefox/60.0
Build ID: 20180605171542

Steps to reproduce:

Go to https://bugzilla.mozilla.org/createaccount.cgi and click on "I have read ...". This should check the box.


Actual results:

Nothing, since the label doesn't have the actual label mark-up.


Expected results:

The HTML should contain be:
<input id="etiquette" value="agreed" type="checkbox">
<label for="etiquette">
      I have read <a href="page.cgi?id=etiquette.html">Bugzilla Etiquette</a>
      and the <a href="https://www.mozilla.org/about/governance/policies/participation/">Mozilla Community Participation Guidelines</a>
      and agree to abide by them.
</label>
The relevant code is here: https://github.com/mozilla-bteam/bmo/blob/master/extensions/BMO/template/en/default/account/create.html.tmpl#L159-L162

If you have a GitHub account, you can edit the source and submit a pull request directly from there :)
Component: General → Extensions: BMO
Keywords: good-first-bug
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: access
Assignee: nobody → joerg
Status: NEW → ASSIGNED
Attached file pull request by joerg
PR merged to master.
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Component: Extensions: BMO → Extensions
You need to log in before you can comment on or make changes to this bug.