POP/SMTP lists, unnecessary baleful uniqueness check for user names

RESOLVED WORKSFORME

Status

SeaMonkey
MailNews: Account Configuration
--
minor
RESOLVED WORKSFORME
16 years ago
14 years ago

People

(Reporter: Wolf Eichler, Assigned: racham)

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
I did a lot of testing with multiple accounts settings recently. I found the
most demanding feature there is SMTP management. I have listed several bugs for
this. My account setting has a multitude of email addresses (i.e. one per
account) split over several host accounts with *the same provider, i.e. the same
server address*. This might be an important information for bug search / design
topics.

This bug: POP server entries, unnecessary baleful uniqueness check for user
names (?)

The story goes like this:
I have 3 GMX host accounts, each of them can hold up to ten email addresses. Say
I defined 15 email addresses spread over these three host accounts. In Mozilla
one address makes up one "Account", so I need to define 15 Mozilla Acounts.
According to prevailing philosophy it would suffice to have just three SMTP
entries, say

#START LIST
mail.gmx.de : 1425678
mail.gmx.de : 1425899
mail.gmx.de : 9839829
#END LIST

The numbers are the host user names (see Bug #147010 for this listing
appearance), one for each host account.
Now, Mozilla makes such economy difficult because it automatically inserts a new
SMTP entry (identical with the POP server definition) during setting up a new
Account.  Here it checks for uniqueness of host user names (for POP server
definition). It is not possible to enter the same host account identity for
several Mozilla Accounts. 

As a result I have to apply an alternative host user name consisting of the
email address. By this my SMTP server list automatically grows linear with the
number of Mozilla Accounts; I can reduce it manually aftermatch.

Resumee:
I cannot see why uniqueness is necessary for entering host identities for POP
server definition. Because there are more than one benefits from it, I suggest
to remove that restriction. Furthermore, the program object that controls SMTP
list should prevent double entries for the pair <hostname> : <username>. By this
the SMTP list will stay at a minimum extent (as originally intended).

- Wolf Eichler
Reporter: Can you reproduce this bug with a recent build of Mozilla (for
example, 1.4 RC1)? If so, then please comment again with details. If not, then
please resolve this bug as WORKSFORME. Thanks.

Comment 2

15 years ago
no response-->resolving wfm
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.