I get a mysterious error at startup (not enough information given in error)

RESOLVED DUPLICATE of bug 193638

Status

Core Graveyard
Profile: BackEnd
RESOLVED DUPLICATE of bug 193638
16 years ago
2 years ago

People

(Reporter: Ken Beal, Assigned: Matti)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.0rc3)
Gecko/20020523
BuildID:    2002052306

I get an error at startup (for the past couple weeks, not sure what caused this
error but it has appeared every time I start, and I've installed RC1, RC2, and
now RC3 and it still occurs).

I will attach a bitmap of the error, but basically it says "Configuration
Warning" as the title, and the body is:

"An error occurred reading the startup configuration file.  Please contact your
administrator.

line 146: ReferenceError: user_ is not defined."

There's an "OK" button.

1. I didn't change any startup file, so I'm not sure why this error started
occurring.

2. The error should be more specific: *which* startup file is the error
occurring in, so I can fix it?

Fortunately, Mozilla appears to function normally after I click "OK".

Reproducible: Always
Steps to Reproduce:
1. Start Mozilla.  The error also occurs when Mozilla quick-starts, when I first
login.

Actual Results:  I get the attached popup.

Expected Results:  Started normally.
(Reporter)

Comment 1

16 years ago
Created attachment 85055 [details]
Error popup

This is the error popup mentioned in the bug.

Comment 2

16 years ago
a shot in the dark, but prefs.js in your profile dir is for instance a
configuration file. Have you modified anything there?
(Reporter)

Comment 3

16 years ago
R.K.Aa: Thanks, I found the file and it ended with a line containing just
"user_".  All the other lines were of the form: "user_pref("something", true)".

So something had modified that file incorrectly (I never touched it manually).

However, even though my problem is solved I still deem this a bug, since the
dialog box should point me in the direction of solving the problem rather than
just say, "PROBLEM EXISTS CONTACT ADMIN."

Out of curiosity, is it possible that when Mozilla crashes, it leaves the
configuration file that way?  If so that's really bad, and if that's the case
this bug should be a "data loss" bug.
(Assignee)

Comment 4

16 years ago
Is it fixed with a new profile ?
Component: Browser-General → Profile Manager BackEnd
(Reporter)

Comment 5

16 years ago
Matthias Versen (Matti): Yes.  Well, all I did was remove the last line (the one
that was simply "user_"), and the error went away.

As I said, though, the error dialog needs to show more information.

Comment 6

16 years ago
On the odd occation a crash can lead to truncated prefs.js (and worse).
Bug 98476, bug 123929 and more deal with this. Resolving as dup of bug 98476..

Related: bug 107264

*** This bug has been marked as a duplicate of 98476 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
(Assignee)

Comment 7

15 years ago
.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
(Assignee)

Comment 8

15 years ago

*** This bug has been marked as a duplicate of 193638 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago15 years ago
Resolution: --- → DUPLICATE
Blocks: 193638
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.