Closed Bug 1470879 Opened 3 years ago Closed 2 years ago

Soundcloud progress bar timer is stuck after pausing/playing a song from the media notification bar

Categories

(Firefox for Android Graveyard :: Audio/Video, defect)

Firefox 62
ARM
Android
defect
Not set
normal

Tracking

(fennec?, firefox60 affected, firefox61 affected, firefox62 affected, firefox63 affected)

RESOLVED INVALID
Tracking Status
fennec ? ---
firefox60 --- affected
firefox61 --- affected
firefox62 --- affected
firefox63 --- affected

People

(Reporter: levente.sacal, Unassigned)

Details

Device(s):
 -  Samsung S8+ (Android 8.0.0);
 -  Sony Xperia Z5 (Android 7.0);

Build(s):
 - Nightly 62.0a1 (2018-06-24);
 - Beta 61.0b15 
 - Release 60.0.2

Steps to reproduce:
 1. Go to soundcloud.com
 2. Play a song.
 3. Pause and play the song from the Android media notification bar.

Expected result:
- Progress bar timer should work after pausing and playing the song again

Actual result:
- The progress bar timer is stuck at 

Notes:
- The audio still keeps on playing even when the timer is stucked
- After pausing and playing the song again from the  browser, the timer works correctly.


https://www.youtube.com/watch?v=O6_KVqqFG-c&feature=youtu.be
Alex, would you mind taking a first look at this?
Flags: needinfo?(achronop)
This must not be a problem in browser side. Soundcloud implements it's own bar they must have a bug there. The same behavior happens on Chrome. I will send a request in there customer service.
Flags: needinfo?(achronop)
The fix is in the pipeline. Will hopefully be out either later today or next week.

We also support the media session API, but due to a configuration error this was not enabled. Does Firefox support this api? I noticed in the compatibility table it is all '?'

https://developer.mozilla.org/en-US/docs/Web/API/MediaSession

Thanks
Thank you for the confirmation. No we are not supporting MediaSeesion API, and I am not sure about the timeline, :jib do you know if we plan to support MediaSession API soon?
Status: NEW → RESOLVED
Closed: 2 years ago
Flags: needinfo?(jib)
Resolution: --- → INVALID
Looks like an incubator spec only supported by Chrome for Android. I don't see it on our roadmap. Checking with jya to see if this is an omission.
Flags: needinfo?(jib) → needinfo?(jyavenard)
Flags: needinfo?(jyavenard)
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.