Update cubeb from upstream to 2968cba

RESOLVED FIXED in Firefox 62

Status

()

defect
P2
normal
Rank:
19
RESOLVED FIXED
10 months ago
9 months ago

People

(Reporter: achronop, Assigned: achronop)

Tracking

unspecified
mozilla63
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox62+ fixed, firefox63 fixed)

Details

Attachments

(2 attachments)

(Assignee)

Description

10 months ago
Pick commits:
2968cba wasapi: Reduce timeout threshold (#447)
27be938 audiounit: new method on failed stream init to avoid deadlock (BMO 1470113). (#445)
bf2c281 cubeb_winmm.c: Don't define __MSVCRT_VERSION__.
(Assignee)

Updated

10 months ago
Assignee: nobody → achronop
Rank: 19
Priority: -- → P2
(Assignee)

Updated

10 months ago
Comment hidden (mozreview-request)

Comment 2

10 months ago
mozreview-review
Comment on attachment 8987786 [details]
Bug 1471164 - Update cubeb from upstream to 2968cba.

https://reviewboard.mozilla.org/r/253064/#review259996
Attachment #8987786 - Flags: review?(padenot) → review+

Comment 3

10 months ago
Pushed by achronop@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/6b9607c2eb18
Update cubeb from upstream to 2968cba. r=padenot

Comment 4

10 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/6b9607c2eb18
Status: NEW → RESOLVED
Last Resolved: 10 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla63
The __MSVCRT_VERSION__ fix is something I'd like to backport to esr60... what would be the best way to do that? cherry-pick that individually?
Flags: needinfo?(padenot)
We usually do the following:
- cherry-pick the patch from trunk, put it in `media/libcubeb`, add it for check in.
- add a line to `media/libcubeb/update.sh`, adding the right patch command call to apply the patch file (like so [0])
- make a regular commit stating the changes. This should include the patch file, the file that has been patch, and the modification to `update.sh`.

This is maybe a slightly unusual process, but the rationale here is to be able to know the base revision of libcubeb that is in the tree, and what exactly have been back-ported (or sometimes added on top, for example for a gecko-specific patch), and all that easily. Let me know if I can be of any help.

[0]: https://hg.mozilla.org/releases/mozilla-esr60/file/tip/media/libcubeb/update.sh#l78
Flags: needinfo?(padenot)

Comment 7

10 months ago
I attached such esr60 version to bug 1471016.
Alex, can you request beta uplift for this patch (re: https://bugzilla.mozilla.org/show_bug.cgi?id=1470113#c5)
Flags: needinfo?(achronop)
(Assignee)

Comment 9

9 months ago
Approval Request Comment
[Feature/Bug causing the regression]: Bug 1466066
[User impact if declined]: crash when request to play audio and the request fail
[Is this code covered by automated tests?]: no
[Has the fix been verified in Nightly?]: yes
[Needs manual test from QE? If yes, steps to reproduce]: N/A 
[List of other uplifts needed for the feature/fix]:
It is not needed but I have created this uplift patch on the top of beta uplift for Bug 1469152. I have done that because it would conflict otherwise. If you are not planning to uplift the other bug let me know to update it.
[Is the change risky?]: No
[Why is the change risky/not risky?]: It has been working well on Nightly and it's rather small
[String changes made/needed]:N/A
Flags: needinfo?(achronop)
Attachment #8991357 - Flags: review?(padenot)
Attachment #8991357 - Flags: approval-mozilla-beta?
Attachment #8991357 - Flags: review?(padenot) → review+
Comment on attachment 8991357 [details] [diff] [review]
Bug 1471164 - Beta uplift for cubeb crash in stream destroy.

Fix for audio crash, it's been on nightly for a while, let's take this for beta 8.
Attachment #8991357 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
You need to log in before you can comment on or make changes to this bug.