The New Tab Page is briefly displayed before the about:welcome page when a new Beta profile is opened

VERIFIED FIXED in Firefox 63

Status

()

defect
P1
normal
VERIFIED FIXED
10 months ago
9 months ago

People

(Reporter: cmuresan, Assigned: ahillier)

Tracking

({regression})

62 Branch
Firefox 63
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox-esr52 unaffected, firefox-esr60 unaffected, firefox61 unaffected, firefox62 wontfix, firefox63 verified)

Details

Attachments

(3 attachments)

[Affected versions]:
- Firefox Beta v62.0b3, Build ID 20180625141512

[Affected Platforms]:
- All Windows
- All Mac
- All Linux

[Steps to reproduce]:
1. Create a new Firefox profile.
2. Start the browser with the new profile and observe the behavior.

[Expected results]:
- The "about:welcome" page is displayed as soon as the browser starts.

[Actual results]:
- The "about:newtab" page is briefly displayed before the "about:welcome" one.

[Notes]:
- The issue is not reproducible on slower machines.
- This issue is not reproducible on Nightly because the about:welcome page is not set as the first run page.
- Attached a screen recording of the issue: https://goo.gl/J3amc9.

Updated

10 months ago
Assignee: nobody → ahillier
Iteration: --- → 63.1 - July 9
Priority: -- → P1

Updated

10 months ago
Iteration: 63.1 - July 9 → 63.2 - July 23
Comment hidden (mozreview-request)
(Assignee)

Comment 3

10 months ago
There are two components to this. The GitHub PR uses CSS to hide ActivityStream while the startup overlay is rendered, which fixes the problem as long as the page is not prerendered. The MC patch disables prerendering for about:welcome. The changes are independent of each other and don't have to land at the same time, or in a particular order.

Comment 4

10 months ago
mozreview-review
Comment on attachment 8991105 [details]
Bug 1471243 - Do not prerender ActivityStream for about:welcome

https://reviewboard.mozilla.org/r/256094/#review263138

::: browser/components/newtab/aboutNewTabService.js:195
(Diff revision 1)
> +   * Returns the about:welcome URL
> +   *
> +   * This is calculated in the same way the default URL is, except that we don't
> +   * allow prerendering.
> +   */
> +  get welcomeURL() {

This is a little brittle but I don't really see a way around it without significant refactoring. The tests are a good compromise
Attachment #8991105 - Flags: review?(khudson) → review+

Updated

10 months ago
Status: NEW → RESOLVED
Last Resolved: 10 months ago
Resolution: --- → FIXED

Updated

10 months ago
Blocks: 1474338

Comment 6

10 months ago
Pushed by khudson@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/1d78b255d77b
Do not prerender ActivityStream for about:welcome r=k88hudson

Comment 7

10 months ago
(In reply to Pulsebot from comment #6)
> Pushed by khudson@mozilla.com:
> https://hg.mozilla.org/integration/autoland/rev/1d78b255d77b
> Do not prerender ActivityStream for about:welcome r=k88hudson

k88hudson: will not pre-rendering AS impact how quickly AS loads after a user finishes up with about:welcome or clicks the skip button? Having AS completely loaded and ready to be displayed after about:welcome was one of the tangible benefits that we could see with about:welcome. Thanks
Flags: needinfo?(khudson)
In this case, not pre-rendering should have no effect on how quickly the rest of new tab can load since the page is able to continue to load in the background while the overlay is visible; pre-rendering just incorrectly flashes the white page with search / placeholders before the overlay is able to load.
Flags: needinfo?(khudson)

Comment 9

10 months ago
(In reply to Kate Hudson :k88hudson from comment #8)
> In this case, not pre-rendering should have no effect on how quickly the
> rest of new tab can load since the page is able to continue to load in the
> background while the overlay is visible; pre-rendering just incorrectly
> flashes the white page with search / placeholders before the overlay is able
> to load.

Makes sense and just wanted to clarify. Thanks!

Comment 11

10 months ago
Commit pushed to master at https://github.com/mozilla/activity-stream

https://github.com/mozilla/activity-stream/commit/ecc4456e4cdfcb0acc1fec34bd656978f4ca9658
fix(styles): Use longhand background to avoid replacing themed background-color (#4239)

Followup Bug 1471243 to fix browser_ext_themes_ntp_colors.js mochitest failure.
Is this something we want to fix in 62?
Flags: needinfo?(ahillier)
(Assignee)

Comment 15

9 months ago
Bryan is it a problem from a UX perspective if we have about:welcome in 62 without this fix?
Flags: needinfo?(ahillier) → needinfo?(bbell)
I have verified that the issue is no longer reproducible on the latest Nightly build (63.0a1, 20180718220144) on Windows 10 x64, Mac 10.13.5 and Arch Linux x64.
Status: RESOLVED → VERIFIED
Adam, this bug appears to be stuck. Did you hear back from Bryan about uplifting to 62? Time's running short in the cycle.
Flags: needinfo?(ahillier)
Yeah, time is running out and about:welcome as-is is on the train for a Fx62 release.
(Assignee)

Comment 19

9 months ago
Sorry about the delay, it's safe to say we won't be requesting uplift for this. Thanks.
Flags: needinfo?(bbell)
Flags: needinfo?(ahillier)
You need to log in before you can comment on or make changes to this bug.