Closed Bug 1471366 Opened 2 years ago Closed 2 years ago

Crash in [@ CrashReporter::TerminateHandler | std::__terminate][@ nsColorPicker::GetHexStringFromNSColor]

Categories

(Core :: Widget: Cocoa, defect, critical)

62 Branch
Unspecified
macOS
defect
Not set
critical

Tracking

()

RESOLVED FIXED
mozilla63
Tracking Status
firefox-esr52 --- unaffected
firefox-esr60 --- unaffected
firefox61 --- unaffected
firefox62 + fixed
firefox63 --- fixed

People

(Reporter: whimboo, Assigned: spohl)

References

Details

(Keywords: crash, regression)

Crash Data

This bug was filed from the Socorro interface and is
report bp-0fa1b1fc-dbe2-4bd1-9f6f-f6cff0180626.
=============================================================

Top 10 frames of crashing thread:

0 XUL CrashReporter::TerminateHandler toolkit/crashreporter/nsExceptionHandler.cpp:1435
1 libc++abi.dylib std::__terminate 
2 libc++abi.dylib __cxa_throw 
3 libobjc.A.dylib objc_exception_throw 
4 CoreFoundation +[NSException raise:format:] 
5 XUL nsColorPicker::GetHexStringFromNSColor widget/cocoa/nsColorPicker.mm:140
6 XUL -[NSColorPanelWrapper colorChanged:] widget/cocoa/nsColorPicker.mm:170
7 AppKit -[NSApplication sendAction:to:from:] 
8 AppKit __61-[NSColorPanel _forceSendAction:notification:firstResponder:]_block_invoke 
9 AppKit -[NSColorPanel _withColorSettingDisabled:] 

=============================================================
Blocks: 1270217
Keywords: regression
Version: 60 Branch → 62 Branch
jwatt, it seems your patch regressed this -- can you take a look?
Flags: needinfo?(jwatt)
Tracking for 62, while this color picker issue isn't a big top crash, it is new in 62 and should be fixable.
This is due to the linker flags added in bug 1289847, and most likely due to an SDK switch thereafter that made it no longer possible for our code to catch and handle exceptions raised by native code. This could be manifesting in a number of odd crashes because our code used to handle a number of possible native exceptions. We should prioritize the work in bug 1290972 as soon as possible. I have confirmed locally that removing these linker flags allows our code to handle native exceptions again.
Blocks: 1290972
Depends on: 1293593, 1289847
Flags: needinfo?(jwatt)
Duplicate of this bug: 1392431
Bug 1290972 just landed, which fixes this.
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Assignee: nobody → spohl.mozilla.bugs
Target Milestone: --- → mozilla63
Crash Signature: [@ CrashReporter::TerminateHandler | std::__terminate] → [@ CrashReporter::TerminateHandler | std::__terminate] [@ objc_exception_throw | +[NSException raise:format:] | nsColorPicker::GetHexStringFromNSColor ]
You need to log in before you can comment on or make changes to this bug.