Switching vertical/horizontal mode transition is not smooth

RESOLVED FIXED in Firefox 63

Status

defect
P1
normal
RESOLVED FIXED
Last year
10 months ago

People

(Reporter: magicp.jp, Assigned: Gijs)

Tracking

({regression})

Trunk
Firefox 63
Dependency tree / graph

Firefox Tracking Flags

(firefox-esr52 unaffected, firefox-esr60 unaffected, firefox61 unaffected, firefox62 wontfix, firefox63 fixed)

Details

(Whiteboard: [good first verify])

Attachments

(2 attachments)

Reporter

Description

Last year
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:63.0) Gecko/20100101 Firefox/63.0 ID:20180629100106

Steps to reproduce:
1. Start Nightly
2. Open Inspector (Ctrl+Shift+C)
3. Click toolbox menu button > Select "Dock to right"
4. Click toolbox menu button > Select "Dock to bottom"


Actual results:
In step 3 or 4, vertical/horizontal mode transition is not smooth than DevEdition.


Expected results:
Same with DevEdition.


Regression range:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=eb6d71b705a88c45709df89964b467c064bde5ca&tochange=47192c4defebb794d611429cd5d98699a9cd3478
Reporter

Updated

Last year
Blocks: 1448096
Assignee

Comment 1

Last year
to avoid flicker/delays, immediately enforce we update the size of the inspector once the devtools move from one place to another.
Assignee

Updated

Last year
Assignee: nobody → gijskruitbosch+bugs
Status: NEW → ASSIGNED
Assignee

Comment 2

Last year
Comment on attachment 8989759 [details]
Bug 1472364 - immediately propagate resizes triggered through changing toolbox hosts, r?bgrins

I know I miss phab reviews because they dont' show up in request.cgi or the requests notifier icon on bugzilla, so I'm just going to add this request here in case bgrins is like me in that respect... :-)
Attachment #8989759 - Flags: review?(bgrinstead)
Priority: -- → P1
Comment on attachment 8989759 [details]
Bug 1472364 - immediately propagate resizes triggered through changing toolbox hosts, r?bgrins

Left comments in Phabricator
Attachment #8989759 - Flags: review?(bgrinstead)
Comment on attachment 8989759 [details]
Bug 1472364 - immediately propagate resizes triggered through changing toolbox hosts, r?bgrins

Brian Grinstead [:bgrins] has approved the revision.

https://phabricator.services.mozilla.com/D1941
Attachment #8989759 - Flags: review+

Comment 6

Last year
Pushed by gijskruitbosch@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/1d40377d3c25
immediately propagate resizes triggered through changing toolbox hosts, r=bgrins
Assignee

Comment 8

Last year
(In reply to Andrei Ciure[:andrei_ciure_] from comment #7)
> Backed out 1 changesets (bug 1472364) for devtools failures
> browser_toolbox_hosts.js
> 
> push that caused the backout:
> https://treeherder.mozilla.org/#/
> jobs?repo=autoland&revision=1d40377d3c2558da69e641df37ab1948d91050ea
> 
> failure:
> https://treeherder.mozilla.org/#/
> jobs?repo=autoland&fromchange=8a33f3ed0b33eddd70b786ba46723462f3dd5115&filter
> -resultStatus=testfailed&filter-resultStatus=busted&filter-
> resultStatus=exception&filter-
> classifiedState=unclassified&selectedJob=187222463&filter-
> searchStr=Linux+opt+Mochitests+with+e10s+test-linux32%2Fopt-mochitest-
> devtools-chrome-e10s-2+M-e10s%28dt2%29
> 
> log:
> https://treeherder.mozilla.org/logviewer.html#?job_id=187222463&repo=autoland
> 
> backout:
> https://hg.mozilla.org/integration/autoland/rev/
> da82daa4f17507cf40d2421001da3eb36dcb324e

Ugh. So the toolbox gets destroyed very quickly in that test, and that trips up the 3Pane check because `this.target` is null (set to null in destroy() ). Added a check and comment for that. Let's doublecheck that's everything:

https://treeherder.mozilla.org/#/jobs?repo=try&revision=7d9b71730406357f005f17c4a540914da7ebabb6
Assignee

Updated

Last year
Flags: needinfo?(gijskruitbosch+bugs)

Comment 9

Last year
Pushed by gijskruitbosch@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/408c06f1c715
immediately propagate resizes triggered through changing toolbox hosts, r=bgrins

Comment 10

Last year
bugherder
https://hg.mozilla.org/mozilla-central/rev/408c06f1c715
Status: ASSIGNED → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → Firefox 63
Marking as GFV due to the ease of the steps to reproduce.
Whiteboard: [good first verify]
You need to log in before you can comment on or make changes to this bug.