-MG in clang-cl suppresses missing-include errors during compilation

RESOLVED FIXED in Firefox 63

Status

defect
RESOLVED FIXED
Last year
Last year

People

(Reporter: jgilbert, Assigned: jgilbert)

Tracking

61 Branch
mozilla63
Dependency tree / graph

Firefox Tracking Flags

(firefox63 fixed)

Details

Attachments

(1 attachment)

Assignee

Description

Last year
My god this was annoying to track down.

I ran into this while vendoring an ANGLE update, and got this:

> 0:01.38 c:/dev/mozilla/gecko1/gfx/angle/checkout/src/common/uniform_type_info_autogen.cpp(99,7):  error: use of undeclared identifier 'GL_SAMPLER_2D_RECT_ANGLE'
> 0:01.38      {GL_SAMPLER_2D_RECT_ANGLE, GL_INT, GL_TEXTURE_2D, GL_NONE, GL_NONE, 1, 1, 1, sizeof(GLint),
> 0:01.38       ^
> 0:01.41 c:/dev/mozilla/gecko1/gfx/angle/checkout/src/common/uniform_type_info_autogen.cpp(222,14):  error: use of undeclared identifier 'GL_SAMPLER_2D_RECT_ANGLE'
> 0:01.41         case GL_SAMPLER_2D_RECT_ANGLE:
> 0:01.41              ^

That's weird, since that should be being included properly.

Eventually, I was staring down this:

> #include "no_such_file_anywhere_asdfasdfasdf"
> #error FOO

./mach build was showing me /only/ the #error FOO error.

./mach build -v gave me the command line args, and that lead me to -MG probably not being what we want in _DEPEND_CFLAGS for clang-cl, or at least it having unexpected behavior for development.
Comment hidden (mozreview-request)

Comment 2

Last year
mozreview-review
Comment on attachment 8988964 [details]
Bug 1472402 - -MG for clang-cl breaks missing-include error reporting. -

https://reviewboard.mozilla.org/r/254080/#review260820

Whoops, sorry about that!
Attachment #8988964 - Flags: review?(nfroyd) → review+
Also, thank you for tracking this down!

Comment 4

Last year
Pushed by jgilbert@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/9935b243c9a3
MG for clang-cl breaks missing-include error reporting. - r=froydnj

Comment 5

Last year
bugherder
https://hg.mozilla.org/mozilla-central/rev/9935b243c9a3
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → mozilla63
You need to log in before you can comment on or make changes to this bug.