Inspector doesn't react to changes in rules panel (3-pane mode)

RESOLVED DUPLICATE of bug 1330544

Status

defect
P3
normal
RESOLVED DUPLICATE of bug 1330544
Last year
Last year

People

(Reporter: mbalfanz, Unassigned)

Tracking

(Blocks 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Posted video 3-pane.mp4
In 3-pane mode, the animation inspector doesn't update when the user makes changes in the rules panel.  The user needs to first leave and then re-enter the panel for the changes to be visible.

STR:
1. Open a website with animations, like [1]
2. Inspect the iframe / animation
3. Set the inspector into 3-pane mode
4. make changes in the rules panel, e.g. by adding a timing function

Expected result:
- Animation Inspector reflects the changes made in the rules panel

Actual result:
- Animation Inspector does not show the changes made in the rules panel until panel is closed and reopened.

Please see video attached.


[1]: https://developer.mozilla.org/en-US/docs/Web/CSS/CSS_Animations/Using_CSS_animations#Making_it_move_back_and_forth
Thanks Martin.

This looks same to bug 1330544.
I'll fix the bug, please confirm again after fixing.
See Also: → 1330544
Priority: -- → P3
I can confirm this is fixed by bug 1330544. I tried following the steps in Martin's video and the graphs now update.
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → DUPLICATE
Duplicate of bug: 1330544
You need to log in before you can comment on or make changes to this bug.