Implement *ErrorFields from Payment Request spec

RESOLVED DUPLICATE of bug 1435161

Status

()

enhancement
RESOLVED DUPLICATE of bug 1435161
10 months ago
8 months ago

People

(Reporter: marcosc, Assigned: edenchuang)

Tracking

unspecified
Points:
---
Bug Flags:
qe-verify -

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

10 months ago
Implement support for:

 * AddressErrorFields
 * PayerErrorFields
 * Generic `error`

Which can be used with updateWith() and retry().
(Reporter)

Updated

9 months ago
Priority: -- → P2
(Reporter)

Comment 1

9 months ago
Generic `error` member on PaymentValidationErrors, for .retry():
https://github.com/w3c/payment-request/pull/747

PayerErrors:
https://github.com/w3c/payment-request/pull/750

Might split this into two bugs... let's see how big the implementation gets.
Priority: P2 → P3
Whiteboard: [webpayments-reserve]
Flags: qe-verify-
(Assignee)

Comment 2

8 months ago
Merge the implementation into the retry implementation. Set this bug as duplicated bug 1435161.
Assignee: nobody → echuang
Status: NEW → RESOLVED
Last Resolved: 8 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1435161
Priority: P3 → --
Whiteboard: [webpayments-reserve]
You need to log in before you can comment on or make changes to this bug.