Closed Bug 1473216 Opened 3 years ago Closed 3 years ago

Only Firefox shows the permission doorhanger on autoplaying media element without user intaraction

Categories

(Core :: Audio/Video: Playback, defect, P2)

defect

Tracking

()

RESOLVED WONTFIX

People

(Reporter: tetsuharu, Unassigned)

References

Details

(Keywords: compat, parity-chrome, parity-safari)

## Summary

By https://groups.google.com/d/topic/mozilla.dev.platform/39Q3fW3zl1E/discussion, Firefox will ships to block audible autoplay, Firefox will shows the doorhanger permission to ask user to allow autoplay.

Other browsers like Chrome or Safari behaves similarly but they does not shows such additional permitting dialogs. I think think would be negative impression for Firefox' UX by too noisy, and I also seem this would have a possibility about web compatibility.


## Environment

* https://hg.mozilla.org/mozilla-central/rev/987ea0d6a000b95cf93928b25a74a7fb1dfe37b2
* Mozilla/5.0 (Macintosh; Intel Mac OS X 10.13; rv:63.0) Gecko/20100101 Firefox/63.0


## Steps to Reproduce

1. Set these prefs guided by https://groups.google.com/d/topic/mozilla.dev.platform/39Q3fW3zl1E/discussion
  * media.autoplay.enabled=false
  * media.autoplay.enabled.user-gestures-needed=true
  * media.autoplay.ask-permission=true 
2. Open a page which has a media element which has autoplay audible.


## Actual Result

* Firefox blocks a media element which has autoplay audible.
* And also Firefox shows the additional doorhanger permission which asks user to allow to autoplay.


## Expected Result

* Firefox does not have to show the additional doorhanger.
* I think it's too noisy as Firefox's UX because other browsers (Chromium and Safari) does not shows the permission dialog/notification to allow to autoplay. They disallow such auto-playing silently.
* I also feel this might be a web compatibly issues.
Priority: -- → P2
Thanks for taking the time to file this bug. We're going to be studying the effect of having the prompt enabled, and will make a decision whether to go ahead with it in due time. Closing this bug for now.
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.