Closed Bug 1473280 Opened 2 years ago Closed 2 years ago

Intermittent Test Verify GECKO(1070) | Assertion failure: mPresContext->mLayoutPhaseCount[eLayoutPhase_FrameC] == 0 (painting in the middle of frame construction), at /builds/worker/workspace/build/src/layout/base/nsAutoLayoutPhase.cpp:42

Categories

(Core :: Layout, defect, P5)

defect

Tracking

()

RESOLVED DUPLICATE of bug 1438939

People

(Reporter: intermittent-bug-filer, Unassigned)

Details

(Keywords: intermittent-failure)

Filed by: btara [at] mozilla.com

https://treeherder.mozilla.org/logviewer.html#?job_id=186308412&repo=mozilla-inbound

https://queue.taskcluster.net/v1/task/AZXGIYihR8qJ-AqRRgbJnw/runs/0/artifacts/public/logs/live_backing.log

16:10:12     INFO - SimpleTest START
16:10:12     INFO - TEST-START | toolkit/components/extensions/test/mochitest/test_ext_webrequest_hsts.html
16:10:12     INFO - GECKO(1070) | ++DOMWINDOW == 7 (0x12857d800) [pid = 1071] [serial = 7] [outer = 0x1280ab800]
16:10:12     INFO - GECKO(1070) | 2018-07-03 16:10:12.778 plugin-container[1073:12405] *** CFMessagePort: bootstrap_register(): failed 1100 (0x44c) 'Permission denied', port = 0x8a3b, name = 'com.apple.tsm.portname'
16:10:12     INFO - GECKO(1070) | See /usr/include/servers/bootstrap_defs.h for the error codes.
16:10:13     INFO - GECKO(1070) | ++DOMWINDOW == 8 (0x12674b800) [pid = 1071] [serial = 8] [outer = 0x1280ab800]
16:10:13     INFO - GECKO(1070) | [Parent 1070, Main Thread] WARNING: NS_ENSURE_SUCCESS(rv, rv) failed with result 0x80040111: file /builds/worker/workspace/build/src/netwerk/protocol/res/SubstitutingProtocolHandler.cpp, line 342
16:10:13     INFO - GECKO(1070) | ++DOCSHELL 0x129d9b000 == 6 [pid = 1070] [id = {e33bdcb2-663e-9a42-a115-c49af7a287b8}]
16:10:13     INFO - GECKO(1070) | ++DOMWINDOW == 13 (0x12ba41400) [pid = 1070] [serial = 13] [outer = 0x0]
16:10:13     INFO - GECKO(1070) | ++DOMWINDOW == 14 (0x119bbc000) [pid = 1070] [serial = 14] [outer = 0x12ba41400]
16:10:13     INFO - GECKO(1070) | ++DOMWINDOW == 15 (0x119bbd400) [pid = 1070] [serial = 15] [outer = 0x12ba41400]
16:10:13     INFO - GECKO(1070) | ++DOMWINDOW == 16 (0x129bec400) [pid = 1070] [serial = 16] [outer = 0x12ba41400]
16:10:13     INFO - GECKO(1070) | ++DOCSHELL 0x12ba7a800 == 7 [pid = 1070] [id = {01e1b2df-cdb7-6944-9b62-c6ed53179599}]
16:10:13     INFO - GECKO(1070) | ++DOMWINDOW == 17 (0x124a37c00) [pid = 1070] [serial = 17] [outer = 0x0]
16:10:13     INFO - GECKO(1070) | ++DOMWINDOW == 18 (0x12beaa000) [pid = 1070] [serial = 18] [outer = 0x124a37c00]
16:10:13     INFO - GECKO(1070) | ++DOMWINDOW == 19 (0x119bbe000) [pid = 1070] [serial = 19] [outer = 0x124a37c00]
16:10:14     INFO - GECKO(1070) | ++DOCSHELL 0x11375b800 == 1 [pid = 1073] [id = {de310f3f-9012-1045-a17d-0c80c6aab39c}]
16:10:14     INFO - GECKO(1070) | ++DOMWINDOW == 1 (0x109e3c200) [pid = 1073] [serial = 1] [outer = 0x0]
16:10:14     INFO - GECKO(1070) | ++DOMWINDOW == 2 (0x11373c800) [pid = 1073] [serial = 2] [outer = 0x109e3c200]
16:10:14     INFO - GECKO(1070) | ++DOCSHELL 0x1280e6800 == 3 [pid = 1071] [id = {f10d5b2e-ce6a-4042-9819-07d7529280d6}]
16:10:14     INFO - GECKO(1070) | ++DOMWINDOW == 9 (0x126772200) [pid = 1071] [serial = 9] [outer = 0x0]
16:10:14     INFO - GECKO(1070) | ++DOMWINDOW == 10 (0x12804a800) [pid = 1071] [serial = 10] [outer = 0x126772200]
16:10:14     INFO - GECKO(1070) | ++DOMWINDOW == 11 (0x128582400) [pid = 1071] [serial = 11] [outer = 0x126772200]
16:10:14     INFO - GECKO(1070) | Console message: [JavaScript Warning: "Use of nsIFile in content process is deprecated." {file: "resource://gre/modules/FileUtils.jsm" line: 170}]
16:10:14     INFO - GECKO(1070) | ### XPCOM_MEM_BLOAT_LOG defined -- logging bloat/leaks to /var/folders/s5/81dr97rn3zqdvv2753kdzqqh00000w/T/tmpCmMNKY.mozrunner/runtests_leaks_tab_pid1074.log
16:10:15     INFO - GECKO(1070) | ++DOMWINDOW == 3 (0x119f2e800) [pid = 1073] [serial = 3] [outer = 0x109e3c200]
16:10:16     INFO - GECKO(1070) | Assertion failure: mPresContext->mLayoutPhaseCount[eLayoutPhase_FrameC] == 0 (painting in the middle of frame construction), at /builds/worker/workspace/build/src/layout/base/nsAutoLayoutPhase.cpp:42
16:10:16     INFO - GECKO(1070) | 2018-07-03 16:10:16.125 plugin-container[1074:12441] *** CFMessagePort: bootstrap_register(): failed 1100 (0x44c) 'Permission denied', port = 0x8a57, name = 'com.apple.tsm.portname'
16:10:16     INFO - GECKO(1070) | See /usr/include/servers/bootstrap_defs.h for the error codes.
16:10:16     INFO - GECKO(1070) | Console message: [JavaScript Warning: "Use of nsIFile in content process is deprecated." {file: "resource://gre/modules/NetUtil.jsm" line: 266}]
16:10:16     INFO - GECKO(1070) | ###!!! [Parent][MessageChannel] Error: (msgtype=0x2D0053,name=PContent::Msg_Activate) Channel error: cannot send/recv
16:10:16     INFO - GECKO(1070) | ###!!! [Parent][MessageChannel] Error: (msgtype=0x160001,name=PBrowser::Msg_AsyncMessage) Channel error: cannot send/recv
16:10:16     INFO - GECKO(1070) | ###!!! [Parent][MessageChannel] Error: (msgtype=0x160001,name=PBrowser::Msg_AsyncMessage) Channel error: cannot send/recv
16:10:16     INFO - GECKO(1070) | ###!!! [Parent][MessageChannel] Error: (msgtype=0x160001,name=PBrowser::Msg_AsyncMessage) Channel error: cannot send/recv
16:10:16     INFO - GECKO(1070) | ###!!! [Parent][MessageChannel] Error: (msgtype=0x160001,name=PBrowser::Msg_AsyncMessage) Channel error: cannot send/recv
16:10:16     INFO - GECKO(1070) | ###!!! [Parent][MessageChannel] Error: (msgtype=0x160001,name=PBrowser::Msg_AsyncMessage) Channel error: cannot send/recv
16:10:16     INFO - GECKO(1070) | ###!!! [Parent][MessageChannel] Error: (msgtype=0x160001,name=PBrowser::Msg_AsyncMessage) Channel error: cannot send/recv
16:10:16     INFO - GECKO(1070) | ###!!! [Parent][MessageChannel] Error: (msgtype=0x160080,name=PBrowser::Msg_Destroy) Channel error: cannot send/recv
16:10:16     INFO - GECKO(1070) | ###!!! [Parent][MessageChannel] Error: (msgtype=0x160080,name=PBrowser::Msg_Destroy) Channel error: cannot send/recv
16:10:16     INFO - GECKO(1070) | ++DOCSHELL 0x124a9c000 == 8 [pid = 1070] [id = {4ac1f0a2-0100-3249-bc97-dcc562e69bbe}]
16:10:16     INFO - GECKO(1070) | ++DOMWINDOW == 20 (0x12c42fc00) [pid = 1070] [serial = 20] [outer = 0x0]
16:10:16     INFO - GECKO(1070) | ++DOMWINDOW == 21 (0x1249a5400) [pid = 1070] [serial = 21] [outer = 0x12c42fc00]
16:10:16     INFO - GECKO(1070) | A content process crashed and MOZ_CRASHREPORTER_SHUTDOWN is set, shutting down
Status: NEW → RESOLVED
Closed: 2 years ago
Component: General → Layout
Product: WebExtensions → Core
Resolution: --- → DUPLICATE
Duplicate of bug: 1438939
You need to log in before you can comment on or make changes to this bug.