Closed Bug 1473974 Opened Last year Closed Last year

Opening tab list with Ctrl+Tab breaks the tab list until browser restart.

Categories

(Firefox :: Tabbed Browser, defect, P1)

defect

Tracking

()

VERIFIED FIXED
Firefox 63
Tracking Status
firefox-esr52 --- unaffected
firefox-esr60 --- unaffected
firefox61 --- unaffected
firefox62 --- verified
firefox63 --- verified

People

(Reporter: tcsc, Assigned: mstriemer)

References

Details

(Keywords: regression)

Attachments

(3 files)

STR:

- Be on macOS (haven't tried other OSes)
- Open a bunch of tabs. Enough so that you need to scroll and the all tabs drop down button shows up.
- Set "Ctrl+Tab cycles through tabs in recent used order" in your preferences.
- Hit ctrl+tab until you're on "List all N tabs" and then release (selecting that option).

After this not only does the tab list not show up, but it is permanently broken until the browser is restarted.
This is present in Beta as well, but not release. It's possible this is a dupe of an existing bug then? I'd be surprised if nobody noticed it (although maybe my usage pattern is rare).
Component: Untriaged → Tabbed Browser
Mozregression says it's due to https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=37c19e77f78dc0d5958daae526006f87a3765630&tochange=0d4eda5546ddd0317e305d42280c58fb8773a66d (which makes sense since that seems like a nontrivial change to that code).

This also renders the "list all tabs" button completely broken, and that remains permanently broken after triggering it, so it seems kind of bad to me.
Blocks: 1446101
Flags: needinfo?(mstriemer)
This issue is reproducible also on Windows.
Has Regression Range: --- → yes
Has STR: --- → yes
Priority: -- → P1
I can confirm this. There are some other keyboard support issues by the looks of things too. Pressing down in the menu won't drop into the list of tabs.
Assignee: nobody → mstriemer
Flags: needinfo?(mstriemer)
Comment on attachment 8991084 [details]
Bug 1473974 - Fix opening all tabs panel with cycle recent tabs

https://reviewboard.mozilla.org/r/256086/#review263078
Attachment #8991084 - Flags: review?(dao+bmo) → review+
Pushed by dgottwald@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/024b40bca61d
Fix opening all tabs panel with cycle recent tabs r=dao
https://hg.mozilla.org/mozilla-central/rev/024b40bca61d
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → Firefox 63
Flags: qe-verify+
Attached image Bug1473974.gif
This issue is verified as fixed on Firefox 63.0a1 (20180711221812) under Win 7 64-bit and Mac OS X 10.13.3.

Please see the attached video.
Status: RESOLVED → VERIFIED
Flags: qe-verify+
Comment on attachment 8991084 [details]
Bug 1473974 - Fix opening all tabs panel with cycle recent tabs

Approval Request Comment
[Feature/Bug causing the regression]: bug 1446101
[User impact if declined]: The all tabs menu stops working when trying to open it with Ctrl+Tab
[Is this code covered by automated tests?]: No
[Has the fix been verified in Nightly?]: Yes
[Needs manual test from QE? If yes, steps to reproduce]: See comment 0
[List of other uplifts needed for the feature/fix]:
[Is the change risky?]: No
[Why is the change risky/not risky?]: Small change to use the new open function for the all tabs menu
[String changes made/needed]: No
Attachment #8991084 - Flags: approval-mozilla-beta?
Comment on attachment 8991084 [details]
Bug 1473974 - Fix opening all tabs panel with cycle recent tabs

Verified in nightly, fix for recent regression in 62; let's uplift for beta 9.
Attachment #8991084 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Attached image Bug1473974.gif
This issue is verified as fixed on Firefox 62.0b9 (20180713213322) under Win 7 64-bit and Mac OS X 10.13.3.

Please see the attached video.
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.