Closed Bug 1474181 Opened 3 years ago Closed 3 years ago

IME preedit text is unreadable (dark grey on black), and prefs have no effect.

Categories

(Core :: Layout: Text and Fonts, defect)

61 Branch
Unspecified
Linux
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1461307

People

(Reporter: cwbussard, Unassigned)

Details

(Keywords: inputmethod)

Attachments

(1 file)

Attached image ffUglyIME.png
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:60.0) Gecko/20100101 Firefox/60.0
Build ID: 20100101

Steps to reproduce:

1.) Enter Japanese text using IME. (In this instance, fcitx on KDE on Debian 9 "Stretch")
2.) Press spacebar OR down arrow.

-------------
Subsequent efforts:
sub.1.) Set all of the prefs described in https://developer.mozilla.org/en-US/docs/Mozilla/IME_handling_guide to #FF0000.
sub.2.) Enter Japanese text using IME.
sub.3.) Press spacebar OR down arrow.


Actual results:

IME preedit text becomes unreadable dark grey on black. See attached imaged.

-----------
Subsequent efforts:
Same result (unreadable dark grey on black). These prefs have no effect.


Expected results:

IME preedit text should use either system colors (white on blue, in my case) or (old?) firefox default colors (black on light grey) or, really, anything that's readable.

-------------
Subsequent efforts:
If these prefs were working, everything should have been red at all times.
Status: UNCONFIRMED → RESOLVED
Has STR: --- → yes
Closed: 3 years ago
Component: Untriaged → Layout: Text
Keywords: inputmethod
OS: Unspecified → Linux
Product: Firefox → Core
Resolution: --- → DUPLICATE
Duplicate of bug: 1461307
You need to log in before you can comment on or make changes to this bug.