Closed Bug 1474255 Opened 4 years ago Closed 4 years ago

All extensions disabled in Firefox 62.0b6 on Ubuntu 18.04 LTS

Categories

(Toolkit :: Add-ons Manager, defect)

62 Branch
x86_64
Linux
defect
Not set
normal

Tracking

()

RESOLVED INVALID

People

(Reporter: Valeryan_24, Unassigned)

References

()

Details

(Keywords: regression)

Attachments

(1 file)

Attached image FF-62.png
User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Ubuntu Chromium/66.0.3359.181 Chrome/66.0.3359.181 Safari/537.36

Steps to reproduce:

On Ubuntu 18.04 LTS, with the ppa Mozilla Firefox Next activated (https://launchpad.net/~mozillateam/+archive/ubuntu/firefox-next), updates this morning, which installed Firefox 62.0b6 64 bits.


Actual results:

At FF restart, all extensions were totally disabled. On the "Tools - Addons" pane, only the button "Remove" is possible, no way to reactive extensions.


Expected results:

Webextensions should continue to work.

Other users seem impacted (see the 2 last comments):
https://blog.mozilla.org/addons/2018/07/05/extensions-in-firefox-62/
Are you using the same Firefox profile in Linux and Windows?
Component: Untriaged → Add-ons Manager
OS: Unspecified → Linux
Product: Firefox → Toolkit
Hardware: Unspecified → x86_64
I only use Linux, Firefox profile is in Ubuntu.

Tried to uninstall and reinstall one of the addons from Mozilla site, got the error message :

"the addon downloaded from this site could not be installed because it appears to be corrupt"
if you're using distro package, it's likely caused by their patch.
(they're patching addon system)
please try mozilla's build to see if it works there.
https://www.mozilla.org/en-US/firefox/beta/all/
Flags: needinfo?(Valeryan_24)
As said in the bug report, I use the ppa from Mozilla team (don't konw if it is an "official" Mozilla dev) :
https://launchpad.net/~mozillateam/+archive/ubuntu/firefox-next

You're right, I should also report there...
Flags: needinfo?(Valeryan_24)
Also present in Ubuntu 16.04 with Firefox 62.0
Console error message when trying to reinstall add-ons: 

>1531148770418	addons.xpi	WARN	Download of https://addons.mozilla.org/firefox/downloads/file/1001903/ublock_origin-1.16.12-an+fx.xpi?src=search failed: TypeError: aAddon._installLocation is undefined (resource://gre/modules/addons/XPIDatabase.jsm:1871:9) JS Stack trace: isUsableAddon@XPIDatabase.jsm:1871:9
updateBlocklistState@XPIDatabase.jsm:562:27

>PopupNotifications._onButtonEvent: Button click happened before the window was focused

>1531148813948	addons.xpi	WARN	Download of https://addons.mozilla.org/firefox/downloads/file/1001903/ublock_origin-1.16.12-an+fx.xpi?src=search failed: TypeError: aAddon._installLocation is undefined (resource://gre/modules/addons/XPIDatabase.jsm:1871:9) JS Stack trace: isUsableAddon@XPIDatabase.jsm:1871:9
updateBlocklistState@XPIDatabase.jsm:562:27


That message is accompanied by a pop-up notification in the browser window which states "The add-on downloaded from this site could not be installed because it appears to be corrupt."
Rico seems to be working on that PPA.
Flags: needinfo?(ricotz)
Could be related to the patch of https://bugzilla.mozilla.org/show_bug.cgi?id=1464766
Flags: needinfo?(ricotz)
Mike, is this related to bug 1464766? Though that seems to affect 61 while this issue may not.
Flags: needinfo?(mh+mozilla)
To complete informations, I jut tried to another computer running this time Ubuntu 18.10 development version: Firefox is also updated from the same Mozilla Team ppa in 62.06b and all addons still work well...

https://launchpadlibrarian.net/377821412/FF62-1810.png
Is this reproducible with a mozilla-provided build?
The line numbers in comment 6 do not align with the contents of the official 62.0b6 release.
Flags: needinfo?(Valeryan_24)
I guess they have a patch to address bug 1464766 and didn't notice that bug 1461217 changed _installLocation to location.
Flags: needinfo?(mh+mozilla)
OK, so does this mean this is an issue for Ubuntu and not Firefox? In that case we can close this bug.
Yes, it's entirely Ubuntu specific. My guess as to what happened is that they took the patch from bug 1464766, backported it to 61, and had to adjust it because of bug 1461217 not being on 61, and then that patch ended up being used in the backported form on 62, which breaks things because of bug 1461217.
Closing as not our bug.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → INVALID
See Also: → 1474038
Hi, bug seems to be resolved with last Ubuntu 18.04 and ppa update, addons were reactivated (some needed to be done manually), thanks for your help !
Flags: needinfo?(Valeryan_24)
You need to log in before you can comment on or make changes to this bug.