RFE: automatically download all new IMAP/NNTP messages for Offline usage (pref-controlled)

RESOLVED DUPLICATE of bug 81303

Status

SeaMonkey
MailNews: Backend
--
enhancement
RESOLVED DUPLICATE of bug 81303
16 years ago
11 years ago

People

(Reporter: llanero, Assigned: Bienvenu)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: $40 donation)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0rc3) Gecko/20020523
BuildID:    2002052309

I have marked all my folder in "Offline & Disk Usage", so they are available
after I disconnect. But when I see that I have 4 mails in "folder1", they are
not downloaded. When I click on "folder1", I can see mozilla mail getting the
headers, and the message are not downloaded until I click on the message.

Reproducible: Always
Steps to Reproduce:
1. Get some mail in you imap account
2. Be sure to have "folder1" configured to be available for offline usage
3. click on "folder1" that has *new* mail.
4. You can see the headers are downloaded when you click
5. You can notice the message in downloaded when you click on it.

Actual Results:  I can't read my imap account offline

Expected Results:  All new messages downloaded (folders synchronized).


Is this *feature* broken in RC3? I have not used imap in previous builds.

Updated

16 years ago
QA Contact: gayatri → gchan

Comment 1

16 years ago
Reporter, I'm confused as to what the problem is?

Using commercial branch:
20020528 on linux 2.2

I followed your steps to reproduce, I went offline, and I was
able to read my downloaded mesgs in the folder marked for offline
use. I clicked on each individual mesg and it downloaded fine.
I then went offline (didn't download rest of the mesgs at the prompt)
and it worked.


I assume you are saying you can't read those mesgs while offline?
Does it happen to all folders (inbox included)?



Assignee: mscott → bienvenu
Component: Mail Back End → Offline
(Assignee)

Comment 2

16 years ago
I can't even tell if the reporter asked Mozilla to download his messages for
offline use, either by doing a File | Offline | Download/Sync Now, or
configuring mozilla to automatically download folders configured for offline use
when going Offline from a mail/news window.
(Reporter)

Comment 3

16 years ago
Sorry, I will try to explain better:

I have Mozilla Mail running all the time.
I have Mozilla Mail configured to check my imap account every 5 minutes.
I have Mozilla Mail configured to download all folders (except Trash) for
offline usage.

What I miss is the option available in POP accounts: "automatically download new
mail messages".

I supose that if you have a folder marked for offline usage, messages in this 
folder get downloaded when they arrive. Perhaps I'm wrong. I didn't know you can
"sync now" in the file menu. Sorry. I was expecting it to autosync as I have
selected them for offline usage.

The problem is that I see I have new mail, and when going to check it, I must
wait for it to download in every folder I open and in every message I click.

I was thinking of this feature as "automatically sync this folders".

Tell me if I'm wrong.

And yes, already clicked (and downloaded) messages are available offline.

Thanks.
(Assignee)

Comment 4

16 years ago
you just need to, in the mail window, pick the File menu, Offline sub menu,
Download and Sync now, and check the mail messages box.

We automatically download messages you read, for offline use if the folder is
configured for offline use. You can also set it up (through Edit | Preferences |
Offline & Disk Space) so that whenever you go offline (by toggling the offline
icon in the bottom right corner of your mail window), we will prompt you to
download any message bodies that you don't have downloaded yet.
(Reporter)

Comment 5

16 years ago
But what I want/need is to have this message bodies downloaded automatically, as
it happens with pop. So I don't need to tell it every time that I wan't to
disconnect or synchronize folders.

Just download to my machine as they arrive. So I can read them fast, not waiting
for every mail I click to download.

Why isn't the "automatically download new messages" as it happens with POP?

Thanks again.
(Assignee)

Comment 6

16 years ago
It sounds like you really want to be using POP. The reason we don't
automatically download all messages whenever you do get new mail is that we're
trying to give the user some control over when that cpu and network intensive
operation happens.
(Reporter)

Comment 7

16 years ago
Ok, I see.

Can this bug be changed to a enhancement/whislist/feature request then?

I would really like to autosync. This is, every time mail is checked (I have 10
new mails in inbox) and messages are moved (or not) to other folders because of
the message filters, download them.

I don't know how imap works, but it seems that I want the same network/cpu usage
that pop generates, but with imap ability to store my mail in different folders
so they are accessible (and separated) from different sources (this is, I have a
mail backup).

Thanks.

Comment 8

16 years ago
David,
i think this is now a dupe of  Alec's bug 81303.

Comment 9

16 years ago
Reporter, if you have no objections, I will me marking
this bug as dupe of bug 81303. I don't think we
are ever going to add imap option 'to automatically
download new mesgs' like we do for pop. And bug 81303
sounds like the closest we'll come to this..
(Reporter)

Comment 10

16 years ago
Ok. Basically is what I want. Have my new mail in my computer so that I can read
offline. I supose that the "Automatic download" will also download new messages
in all folders.

Thanks.

Comment 11

16 years ago
Ok. just another fyi, if you have pref to 'make mesgs in my
inbox available when I am working offline' set, that will
do a 'auto' download of your inbox mesgs only. So when a new
mesg arrives in your inbox as soon as you read it, it will
be automatically downloaded.

marking as dupe of 81303

*** This bug has been marked as a duplicate of 81303 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
verified dup
Status: RESOLVED → VERIFIED

Comment 13

16 years ago
I would like to resurrect this bug, since IMHO this would be a very useful
feature. Obviously, it should be pref-controlled and off by default, but IMHO it
should be available.

Very often I would disconnect my laptop from the net in a hurry, forgetting to
sync before doing it. Very often the net connectivity would suddenly go down and
I would sit waiting for it to come back wishing my mail (at least what arrived
while the connection was up) was downloaded for offline. Very often the
connection would become really slow and I would sit in front of my computer
waiting for a message to load, wishing it was already downloaded for me
automatically as soon as it arrived.

In all of the above scenarious the "autosync" feature would really help. After
all, Mozilla already even has some support form HTTP prefetching, so adding mail
prefetching (which is what autosync essentially is) would only be consistent.

(And BTW, "just use POP" is not an answer - I want *all* my mail folders to
reside on the server, where they are accessible from other machines by a bunch
of means, where they are backed up, etc).

I was trying to come up with a simple implementation of this feature today (I
was thinking about attaching auto-sync to biff). It seems that it would only
require firing of nsMsgOfflineManager::SynchronizeForOffline at appropriate
place(s). Unfortunatelly I couldn't figure out what such an "appropriate place"
would be. I was thinking that firing SynchronizeForOffline for every single biff
(every minute in my setup) would be too inefficient, and it would be nice to
only fire it once biff have determined that we indeed have some new mail.
Unfortunatelly, the biff code seems to involve quite complicated sequence of
indirect calls, so I couldn't figure out where the code handling "yes, we have
new mail" is located. May be I should have searched for it starting from FE, not
from biff - not sure.

Any thought/suggestions? Thanks! 
Severity: major → enhancement
Status: VERIFIED → UNCONFIRMED
OS: Linux → All
Hardware: PC → All
Resolution: DUPLICATE → ---
Summary: imap mail is not downloaded for Offline usage → RFE: automatically download all new IMAP/NNTP messages for Offline usage (pref-controlled)

Updated

16 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 14

15 years ago
I will donate $40 to mozilla.org when this bug is fixed.
Whiteboard: $40 donation

Updated

15 years ago
Blocks: 36011
Product: Browser → Seamonkey

Comment 15

11 years ago
(In reply to comment #13)
> I would like to resurrect this bug, since IMHO this would be a very useful
> feature. 

That's really no reason to reopen the bug, as the original reporter already verified it *is* a duplicate. Please follow bug 81303 instead, if/when it get fixed it will happen over there.
Status: NEW → RESOLVED
Last Resolved: 16 years ago11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 81303
You need to log in before you can comment on or make changes to this bug.