Closed Bug 1474360 Opened 2 years ago Closed Last year

Cannot paste text into input fields

Categories

(GeckoView :: General, defect, P1)

defect

Tracking

(firefox61 wontfix, firefox62+ verified, firefox63+ verified)

VERIFIED FIXED
mozilla63
Tracking Status
firefox61 --- wontfix
firefox62 + verified
firefox63 + verified

People

(Reporter: ekager, Assigned: jchen)

Details

(Keywords: regression, regressionwindow-wanted, Whiteboard: [geckoview:klar:p1])

Attachments

(1 file)

Originally reported on Github https://github.com/mozilla-mobile/focus-android/issues/2867

Steps to reproduce:

1. Copy some text into the clipboard
2. Navigate to any site with an input field, eg: google.com
3. Hold down finger on input field

Expected behavior:

Option appears to paste; user can select to paste text
Actual behavior

A black bar above the page appears briefly with a left facing arrow (left aligned) and "Paste" text (right aligned) and disappears before a user can select Paste.

On Fennec this bar works to allow for paste. On current stable Firefox Klar (from F-Droid) the paste option appears alongside the cursor that appears for input; no bar appears.

Device information:

    Android device: LG-H810, Android 5.1
    Focus version: 6.2 (Build #221891205 Emoji image of 'lizard' 62.0.20180702164905)
P1 because this is a functionality regression compared to Focus+WebView.
Priority: -- → P1
Whiteboard: [geckoview:klar:p1]
Has STR: --- → irrelevant
Jim said he would investigate this bug.
Assignee: nobody → nchen
Comment on attachment 8992682 [details]
Bug 1474360 - Don't immediately hide selection toolbar after showing it;

https://reviewboard.mozilla.org/r/257540/#review264988
Attachment #8992682 - Flags: review?(esawin) → review+
Pushed by nchen@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/090266754d3d
Don't immediately hide selection toolbar after showing it; r=esawin
https://hg.mozilla.org/mozilla-central/rev/090266754d3d
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 63
Comment on attachment 8992682 [details]
Bug 1474360 - Don't immediately hide selection toolbar after showing it;

Approval Request Comment
[Feature/Bug causing the regression]: bug 1441279
[User impact if declined]: Cannot paste text in GeckoView-based apps
[Is this code covered by automated tests?]: Yes
[Has the fix been verified in Nightly?]: Yes
[Needs manual test from QE? If yes, steps to reproduce]: No
[List of other uplifts needed for the feature/fix]: None
[Is the change risky?]: No
[Why is the change risky/not risky?]: GeckoView-only fix
[String changes made/needed]: None
Attachment #8992682 - Flags: approval-mozilla-beta?
Comment on attachment 8992682 [details]
Bug 1474360 - Don't immediately hide selection toolbar after showing it;

Geckoview-only fix, OK to uplift for beta 11.
Attachment #8992682 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Tested with Nexus 5(Android 6.0.1), Samsung Galaxy Note8(Android 8.0) and LG G4(Android 5.1) on latest Beta build (62.0b11) and wasn't able to reproduce the issue. Marking 62:verified.
Verified as fixed on latest Nightly build (08/16).
Device: OnePlus 5T(Android 8.1.0).
Status: RESOLVED → VERIFIED
This should have been verified in Focus or GeckoView example.
Status: VERIFIED → RESOLVED
Closed: 2 years agoLast year
Sorry for the confusion! The issue was verified also on Focus, but re-checked now with LG G4(Android 5.1) on Firefox Klar from F-Droid (version 6.1.1, build #22) and Firefox Focus from Google Play (version 6.1.1, build #322202122) and I can confirm the fix. I was able to paste into the search field e.g. google.com, amazon.com, imdb.com.
Status: RESOLVED → VERIFIED
Product: Firefox for Android → GeckoView
Target Milestone: Firefox 63 → mozilla63
You need to log in before you can comment on or make changes to this bug.