Including any of webconsole|inspector|jsdebugger|styleeditor|netmonitor|storage in extension ID stops created devtools panels from loading

VERIFIED FIXED in Firefox 61

Status

P2
normal
VERIFIED FIXED
8 months ago
7 months ago

People

(Reporter: Kwan, Assigned: Kwan)

Tracking

({regression})

unspecified
mozilla63
regression
Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(firefox-esr52 unaffected, firefox-esr60 unaffected, firefox61- verified, firefox62+ verified, firefox63+ verified)

Details

(URL)

Attachments

(4 attachments, 1 obsolete attachment)

(Assignee)

Description

8 months ago
This should maybe end up in the Devtools product.

STR:
1) Load attached extension in Firefox
2) Open DevTools
3) Click on "Broken Panel" tab in devtools

AR:
Nothing
(Error in Browser console "Error: Unknown event: ["devtools.main", "enter", "webext-devtools-panel-<Ext_ID_WITH_UNDERSCORES>-140-0"]")

ER:
Extension's panel is opened, Success message displayed


For which we can blame this check:
https://dxr.mozilla.org/mozilla-central/rev/085cdfb90903d4985f0de1dc7786522d9fb45596/devtools/client/framework/toolbox.js#3374
against this regex:
https://dxr.mozilla.org/mozilla-central/rev/085cdfb90903d4985f0de1dc7786522d9fb45596/devtools/client/framework/toolbox.js#16

Since the panel IDs include a s/_/<SYMBOLS>/ version of the ext ID.
Comment hidden (mozreview-request)
(Assignee)

Updated

8 months ago
Blocks: 1455270
Keywords: regression

Updated

8 months ago
Component: Untriaged → Developer Tools
Priority: -- → P2

Comment 2

8 months ago
Comment on attachment 8990780 [details]
Bug 1474379 - Match regex against the entire panel ID.

Hi Mike,
do you mind to take a look and review this patch?

It contains a proposed fix for a regressions introduced in Bug 1455270 (which has been landed in Firefox 61).

You can trigger the issue by using the test extension (attachment 8990779 [details]) and the STR provided in comment 0.
Attachment #8990780 - Flags: review?(mratcliffe)
Comment hidden (mozreview-request)
Attachment #8990780 - Flags: review?(mratcliffe) → review+

Comment 4

8 months ago
mozreview-review
Comment on attachment 8991059 [details]
Bug 1474379 - Add test for opening an ext devtools panel when ext ID includes 'inspector'.

https://reviewboard.mozilla.org/r/256052/#review263150

Hi Kwan, thank you so much for reporting and tracking down the underlying issue, and then prepared a fix and a test case for it, you have been truly awesome!

Do you mind to apply on this patch the changes described below, so that I can r+ this patch asap? 

It would be great to land the fix on Nightly asap, especially because once we have landed this (and verified it) on Nightly, we should also create an uplift request, so that we can also apply the fix on Firefox 62 (unfortunately it seems too late for fixing it on Firefox 61, where the change that has introduced this issue has been landed).

::: browser/components/extensions/test/browser/browser_ext_devtools_panel.js:246
(Diff revision 1)
>      browser.test.sendMessage("devtools_panel_inspectedWindow_tabId",
>                               browser.devtools.inspectedWindow.tabId);
>    }
>  
>    const longPrefix = (new Array(80)).fill("x").join("");
>    const EXTENSION_ID = `${longPrefix}@create-devtools-panel.test`;

I guess that adding inspector to this EXTENSION_ID would also ensure that we have a test that prevent that regular expression from regressing without being noticed.

e.g. I would expect that if we change this line into:

```
const EXTENSION_ID = `inspector-${longPrefix}@create-devtools-panel.test`;
```

this test case should fail without the fix applied by the other patch in this queue (and pass with the fix applied).

Opening the developer toolbox is pretty time consuming (especially in debug builds), and so any new entire test case that open and close the toolbox make this test file slower to complete (and then potentially timing out intermittently because it takes longer than the time allowed for a single test file to complete), this is also the reason for the `requestLongerTimeout` that is called in the beginning of this file: https://searchfox.org/mozilla-central/rev/a80651653faa78fa4dfbd238d099c2aad1cec304/browser/components/extensions/test/browser/browser_ext_devtools_panel.js#5-7.

Do you mind to change this patch to include inspector in this EXTENSION_ID and remove the additional test case?
Attachment #8991059 - Flags: review-

Updated

8 months ago
Attachment #8990780 - Flags: review+ → review?(mratcliffe)
Comment hidden (mozreview-request)
(Assignee)

Updated

8 months ago
Attachment #8991059 - Attachment is obsolete: true
(Assignee)

Comment 6

8 months ago
mozreview-review-reply
Comment on attachment 8991059 [details]
Bug 1474379 - Add test for opening an ext devtools panel when ext ID includes 'inspector'.

https://reviewboard.mozilla.org/r/256052/#review263150

> I guess that adding inspector to this EXTENSION_ID would also ensure that we have a test that prevent that regular expression from regressing without being noticed.
> 
> e.g. I would expect that if we change this line into:
> 
> ```
> const EXTENSION_ID = `inspector-${longPrefix}@create-devtools-panel.test`;
> ```
> 
> this test case should fail without the fix applied by the other patch in this queue (and pass with the fix applied).
> 
> Opening the developer toolbox is pretty time consuming (especially in debug builds), and so any new entire test case that open and close the toolbox make this test file slower to complete (and then potentially timing out intermittently because it takes longer than the time allowed for a single test file to complete), this is also the reason for the `requestLongerTimeout` that is called in the beginning of this file: https://searchfox.org/mozilla-central/rev/a80651653faa78fa4dfbd238d099c2aad1cec304/browser/components/extensions/test/browser/browser_ext_devtools_panel.js#5-7.
> 
> Do you mind to change this patch to include inspector in this EXTENSION_ID and remove the additional test case?

Sure, no problem!  I thought about doing that at first, but decided to have a separate one to start since I figured review could either ask that the new test be moved to its own file, or just combined with an existing one like that :)
(Assignee)

Updated

8 months ago
Assignee: nobody → moz-ian
Status: NEW → ASSIGNED
status-firefox61: --- → affected
status-firefox62: --- → affected
status-firefox63: --- → affected

Comment 7

8 months ago
mozreview-review
Comment on attachment 8990780 [details]
Bug 1474379 - Match regex against the entire panel ID.

https://reviewboard.mozilla.org/r/255834/#review263172

Thanks! follows a small nit related to the inline comment (which is not a big deal, and so I'm setting the r+ right away).

::: browser/components/extensions/test/browser/browser_ext_devtools_panel.js:247
(Diff revision 2)
>                               browser.devtools.inspectedWindow.tabId);
>    }
>  
>    const longPrefix = (new Array(80)).fill("x").join("");
> -  const EXTENSION_ID = `${longPrefix}@create-devtools-panel.test`;
> +  // "inspector" included in ID to check including name/ID of built-in panels
> +  // doesn't break opening panel, see bug 1474379

Nit, by convention we usually start the inline comments on mozilla-central with a capitalized letter and it ends with a '.' (and maybe Bug instead of bug).

e.g. this one could be:
```
// Including 'inspector' in the extension id to verify that Bug 1474379 doesn't regress.
```
Attachment #8990780 - Flags: review+
Comment hidden (mozreview-request)
(Assignee)

Comment 9

8 months ago
[Tracking Requested - why for this release]:
Regression that can break extensions whose ID matches a pattern and that make use of a particular API
At least https://addons.mozilla.org/firefox/addon/ember-inspector/ is affected.
tracking-firefox61: --- → ?
tracking-firefox62: --- → ?
tracking-firefox63: --- → ?
Tracking, we can likely still take a patch in 62 beta for this regression. Not sure about 61 though.
tracking-firefox62: ? → +
tracking-firefox63: ? → +
Comment on attachment 8990780 [details]
Bug 1474379 - Match regex against the entire panel ID.

https://reviewboard.mozilla.org/r/255834/#review263624

r+ with just one nit

::: devtools/client/framework/toolbox.js:16
(Diff revision 3)
>  const SPLITCONSOLE_HEIGHT_PREF = "devtools.toolbox.splitconsoleHeight";
>  const DISABLE_AUTOHIDE_PREF = "ui.popup.disable_autohide";
>  const HOST_HISTOGRAM = "DEVTOOLS_TOOLBOX_HOST";
>  const CURRENT_THEME_SCALAR = "devtools.current_theme";
>  const HTML_NS = "http://www.w3.org/1999/xhtml";
> -const REGEX_PANEL = /webconsole|inspector|jsdebugger|styleeditor|netmonitor|storage/;
> +const REGEX_PANEL = /^toolbox-tab-(?:webconsole|inspector|jsdebugger|styleeditor|netmonitor|storage)$/;

This line needs wrapping to avoid eslint failures:

```
const REGEX_PANEL =
  /^toolbox-tab-(?:webconsole|inspector|jsdebugger|styleeditor|netmonitor|storage)$/;
```
Attachment #8990780 - Flags: review?(mratcliffe) → review+
Comment hidden (mozreview-request)
(Assignee)

Comment 13

8 months ago
mozreview-review-reply
Comment on attachment 8990780 [details]
Bug 1474379 - Match regex against the entire panel ID.

https://reviewboard.mozilla.org/r/255834/#review263624

> This line needs wrapping to avoid eslint failures:
> 
> ```
> const REGEX_PANEL =
>   /^toolbox-tab-(?:webconsole|inspector|jsdebugger|styleeditor|netmonitor|storage)$/;
> ```

Huh, weird.  It really should, since the length is 104, the limit to 90[0], and "ignoreRegExpLiterals" isn't on, and yet it doesn't :S (I have the commit lint on).  Changed it anyway.

[0]https://hg.mozilla.org/mozilla-central/file/e951f4ad123a/devtools/.eslintrc.js#l272
(Assignee)

Comment 14

8 months ago
No try run since the change is too trivial to justify it.
Keywords: checkin-needed
(Assignee)

Comment 15

8 months ago
Comment on attachment 8990780 [details]
Bug 1474379 - Match regex against the entire panel ID.

Approval Request Comment
[Feature/Bug causing the regression]: Bug 1455270

[User impact if declined]: Extensions with "inspector" or "storage" in their GUID that implement a devtools panel will break. Fortunately querying the AMO data (https://sql.telemetry.mozilla.org/queries/56921) only 10 extensions seem to match the GUID criteria, and inspecting the listings only Ember Inspector seems to be affected (See URL field).  Although anyone trying to write a new extension with a matching GUID is going to be really frustrated trying to figure out why their panel won't open (which is how I found this ;) )

[Is this code covered by automated tests?]: Yes, updated an existing test to check the issue.

[Has the fix been verified in Nightly?]: Not yet, only on local build, but will do when Nighty's available.

[Needs manual test from QE? If yes, steps to reproduce]: comment #0, or the same with the affected Ember Inspector: https://addons.mozilla.org/firefox/addon/ember-inspector/

[List of other uplifts needed for the feature/fix]: None

[Is the change risky?]: No

[Why is the change risky/not risky?]: Trivial tightening of a regexp to only match what it is supposed to.

[String changes made/needed]: None
Attachment #8990780 - Flags: approval-mozilla-release?
Attachment #8990780 - Flags: approval-mozilla-beta?

Comment 16

8 months ago
Pushed by ryanvm@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/d93abdc258e1
Match regex against the entire panel ID. r=miker,rpl
Keywords: checkin-needed
Backed out changeset d93abdc258e1 (bug 1474379) for failing at test/browser_toolbox_telemetry_enter.js on a CLOSED TREE

Backout link: https://hg.mozilla.org/integration/autoland/rev/910aaebcc00f8cbb12b34a80d67496a3afb88bda

Push with failures: https://treeherder.mozilla.org/#/jobs?repo=autoland&revision=8af3291751e8bf79b1cc5054734ea64ea2afcec9

Log link: https://treeherder.mozilla.org/logviewer.html#?job_id=188054952&repo=autoland&lineNumber=2767

Log snippet: 

[task 2018-07-13T15:15:54.021Z] 15:15:54     INFO - TEST-START | devtools/client/framework/test/browser_toolbox_telemetry_enter.js
[task 2018-07-13T15:15:54.259Z] 15:15:54     INFO - GECKO(1500) | console.log: "test 1"
[task 2018-07-13T15:15:54.259Z] 15:15:54     INFO - GECKO(1500) | console.log: "test 2"
[task 2018-07-13T15:15:54.260Z] 15:15:54     INFO - GECKO(1500) | console.log: "test 3"
[task 2018-07-13T15:15:54.260Z] 15:15:54     INFO - GECKO(1500) | console.log: "test 4"
[task 2018-07-13T15:15:54.261Z] 15:15:54     INFO - GECKO(1500) | console.log: "test 5"
[task 2018-07-13T15:15:57.772Z] 15:15:57     INFO - GECKO(1500) | [ACTION] SET_WORKERS  - {"type":"SET_WORKERS","workers":[]}
[task 2018-07-13T15:15:57.809Z] 15:15:57     INFO - GECKO(1500) | [ACTION] CONNECT  - {"type":"CONNECT","url":"data:text/html;charset=utf8,browser_toolbox_telemetry_enter.js"}
[task 2018-07-13T15:15:57.813Z] 15:15:57     INFO - GECKO(1500) | [ACTION] PAUSE_ON_EXCEPTIONS [start] - {"type":"PAUSE_ON_EXCEPTIONS","shouldPauseOnExceptions":false,"shouldPauseOnCaughtExceptions":true,"seqId":"1","status":"start"}
[task 2018-07-13T15:15:57.834Z] 15:15:57     INFO - GECKO(1500) | [ACTION] PAUSE_ON_EXCEPTIONS [done] - {"type":"PAUSE_ON_EXCEPTIONS","shouldPauseOnExceptions":false,"shouldPauseOnCaughtExceptions":true,"seqId":"1","status":"done","value":{"from":"server1.conn70.child1/context23","type":"paused","actor":"server1.conn70.child1/pause35","poppedFrames":[],"why":{"type":"interrupted"}}}
[task 2018-07-13T15:15:58.057Z] 15:15:58     INFO - GECKO(1500) | [ACTION] SET_ORIENTATION  - {"type":"SET_ORIENTATION","orientation":"horizontal"}
[task 2018-07-13T15:15:59.842Z] 15:15:59     INFO - TEST-INFO | started process screentopng
[task 2018-07-13T15:16:00.161Z] 15:16:00     INFO - TEST-INFO | screentopng: exit 0
[task 2018-07-13T15:16:00.163Z] 15:16:00     INFO - Buffered messages logged at 15:15:54
[task 2018-07-13T15:16:00.164Z] 15:16:00     INFO - Entering test bound 
[task 2018-07-13T15:16:00.164Z] 15:16:00     INFO - TEST-PASS | devtools/client/framework/test/browser_toolbox_telemetry_enter.js | No events have been logged for the main process - 
[task 2018-07-13T15:16:00.169Z] 15:16:00     INFO - Adding a new tab with URL: data:text/html;charset=utf8,browser_toolbox_telemetry_enter.js
[task 2018-07-13T15:16:00.172Z] 15:16:00     INFO - Tab added and finished loading
[task 2018-07-13T15:16:00.172Z] 15:16:00     INFO - Buffered messages logged at 15:15:56
[task 2018-07-13T15:16:00.172Z] 15:16:00     INFO - Console message: [JavaScript Error: "Polling for changes failed: Server error 404 Not Found: "JSON.parse: unexpected character at line 1 column 1 of the JSON data"." {file: "resource://services-settings/remote-settings.js" line: 713}]
[task 2018-07-13T15:16:00.173Z] 15:16:00     INFO - remoteSettingsFunction/remoteSettings.pollChanges@resource://services-settings/remote-settings.js:713:13
[task 2018-07-13T15:16:00.173Z] 15:16:00     INFO - async*notify@jar:file:///builds/worker/workspace/build/application/firefox/omni.ja!/components/RemoteSettingsComponents.js:24:5
[task 2018-07-13T15:16:00.173Z] 15:16:00     INFO - TM_notify/<@jar:file:///builds/worker/workspace/build/application/firefox/omni.ja!/components/nsUpdateTimerManager.js:197:11
[task 2018-07-13T15:16:00.173Z] 15:16:00     INFO - TM_notify@jar:file:///builds/worker/workspace/build/application/firefox/omni.ja!/components/nsUpdateTimerManager.js:244:7
[task 2018-07-13T15:16:00.173Z] 15:16:00     INFO - 
[task 2018-07-13T15:16:00.173Z] 15:16:00     INFO - Buffered messages logged at 15:15:57
[task 2018-07-13T15:16:00.173Z] 15:16:00     INFO - Console message: [JavaScript Warning: "Removed unsafe attribute. Element: svg. Attribute: xlink." {file: "resource://devtools/shared/base-loader.js -> resource://devtools/client/shared/vendor/react-dom.js" line: 5811}]
[task 2018-07-13T15:16:00.173Z] 15:16:00     INFO - Console message: [JavaScript Warning: "Removed unsafe attribute. Element: svg. Attribute: xlink." {file: "resource://devtools/shared/base-loader.js -> resource://devtools/client/shared/vendor/react-dom.js" line: 5811}]
[task 2018-07-13T15:16:00.173Z] 15:16:00     INFO - Console message: [JavaScript Warning: "Removed unsafe attribute. Element: svg. Attribute: xmlns." {file: "resource://devtools/shared/base-loader.js -> resource://devtools/client/shared/vendor/react-dom.js" line: 5811}]
[task 2018-07-13T15:16:00.173Z] 15:16:00     INFO - Buffered messages logged at 15:15:58
[task 2018-07-13T15:16:00.173Z] 15:16:00     INFO - Console message: [JavaScript Warning: "Removed unsafe attribute. Element: svg. Attribute: xmlns." {file: "resource://devtools/shared/base-loader.js -> resource://devtools/client/shared/vendor/react-dom.js" line: 5811}]
[task 2018-07-13T15:16:00.174Z] 15:16:00     INFO - Console message: [JavaScript Warning: "Removed unsafe attribute. Element: svg. Attribute: xmlns." {file: "resource://devtools/shared/base-loader.js -> resource://devtools/client/shared/vendor/react-dom.js" line: 5811}]
[task 2018-07-13T15:16:00.174Z] 15:16:00     INFO - Console message: [JavaScript Warning: "Removed unsafe attribute. Element: svg. Attribute: xmlns." {file: "resource://devtools/shared/base-loader.js -> resource://devtools/client/shared/vendor/react-dom.js" line: 5811}]
[task 2018-07-13T15:16:00.174Z] 15:16:00     INFO - Console message: [JavaScript Warning: "Removed unsafe attribute. Element: svg. Attribute: xmlns." {file: "resource://devtools/shared/base-loader.js -> resource://devtools/client/shared/vendor/react-dom.js" line: 5811}]
[task 2018-07-13T15:16:00.177Z] 15:16:00     INFO - Console message: [JavaScript Warning: "Removed unsafe attribute. Element: svg. Attribute: xlink." {file: "resource://devtools/shared/base-loader.js -> resource://devtools/client/shared/vendor/react-dom.js" line: 5811}]
[task 2018-07-13T15:16:00.177Z] 15:16:00     INFO - Console message: [JavaScript Warning: "Removed unsafe attribute. Element: svg. Attribute: xlink." {file: "resource://devtools/shared/base-loader.js -> resource://devtools/client/shared/vendor/react-dom.js" line: 5811}]
[task 2018-07-13T15:16:00.177Z] 15:16:00     INFO - Console message: [JavaScript Warning: "Removed unsafe attribute. Element: svg. Attribute: xmlns." {file: "resource://devtools/shared/base-loader.js -> resource://devtools/client/shared/vendor/react-dom.js" line: 5811}]
[task 2018-07-13T15:16:00.178Z] 15:16:00     INFO - Console message: [JavaScript Warning: "Removed unsafe attribute. Element: svg. Attribute: xmlns." {file: "resource://devtools/shared/base-loader.js -> resource://devtools/client/shared/vendor/react-dom.js" line: 5811}]
[task 2018-07-13T15:16:00.178Z] 15:16:00     INFO - Console message: [JavaScript Warning: "Removed unsafe attribute. Element: svg. Attribute: xlink." {file: "resource://devtools/shared/base-loader.js -> resource://devtools/client/shared/vendor/react-dom.js" line: 5811}]
[task 2018-07-13T15:16:00.179Z] 15:16:00     INFO - Console message: [JavaScript Warning: "Removed unsafe attribute. Element: svg. Attribute: xlink." {file: "resource://devtools/shared/base-loader.js -> resource://devtools/client/shared/vendor/react-dom.js" line: 5811}]
[task 2018-07-13T15:16:00.184Z] 15:16:00     INFO - Console message: [JavaScript Warning: "Removed unsafe attribute. Element: svg. Attribute: xmlns." {file: "resource://devtools/shared/base-loader.js -> resource://devtools/client/shared/vendor/react-dom.js" line: 5811}]
[task 2018-07-13T15:16:00.186Z] 15:16:00     INFO - Buffered messages logged at 15:15:59
[task 2018-07-13T15:16:00.187Z] 15:16:00     INFO - TEST-PASS | devtools/client/framework/test/browser_toolbox_telemetry_enter.js | timestamp is greater than 0 - 
[task 2018-07-13T15:16:00.188Z] 15:16:00     INFO - TEST-PASS | devtools/client/framework/test/browser_toolbox_telemetry_enter.js | category is correct - 
[task 2018-07-13T15:16:00.189Z] 15:16:00     INFO - TEST-PASS | devtools/client/framework/test/browser_toolbox_telemetry_enter.js | method is correct - 
[task 2018-07-13T15:16:00.190Z] 15:16:00     INFO - Buffered messages finished
[task 2018-07-13T15:16:00.191Z] 15:16:00     INFO - TEST-UNEXPECTED-FAIL | devtools/client/framework/test/browser_toolbox_telemetry_enter.js | object is correct - Got other, expected inspector
[task 2018-07-13T15:16:00.191Z] 15:16:00     INFO - Stack trace:
[task 2018-07-13T15:16:00.192Z] 15:16:00     INFO - chrome://mochikit/content/browser-test.js:test_is:1305
[task 2018-07-13T15:16:00.193Z] 15:16:00     INFO - chrome://mochitests/content/browser/devtools/client/framework/test/browser_toolbox_telemetry_enter.js:checkResults:138
[task 2018-07-13T15:16:00.193Z] 15:16:00     INFO - chrome://mochitests/content/browser/devtools/client/framework/test/browser_toolbox_telemetry_enter.js:null:120
[task 2018-07-13T15:16:00.194Z] 15:16:00     INFO - chrome://mochikit/content/browser-test.js:Tester_execTest/<:1103
[task 2018-07-13T15:16:00.194Z] 15:16:00     INFO - chrome://mochikit/content/browser-test.js:Tester_execTest:1094
[task 2018-07-13T15:16:00.195Z] 15:16:00     INFO - chrome://mochikit/content/browser-test.js:nextTest/<:996
[task 2018-07-13T15:16:00.195Z] 15:16:00     INFO - chrome://mochikit/content/tests/SimpleTest/SimpleTest.js:SimpleTest.waitForFocus/waitForFocusInner/focusedOrLoaded/<:795
[task 2018-07-13T15:16:00.196Z] 15:16:00     INFO - TEST-PASS | devtools/client/framework/test/browser_toolbox_telemetry_enter.js | value is correct - 
[task 2018-07-13T15:16:00.197Z] 15:16:00     INFO - TEST-PASS | devtools/client/framework/test/browser_toolbox_telemetry_enter.js | host is correct - 
[task 2018-07-13T15:16:00.198Z] 15:16:00     INFO - TEST-PASS | devtools/client/framework/test/browser_toolbox_telemetry_enter.js | width is greater than 0 - 
[task 2018-07-13T15:16:00.199Z] 15:16:00     INFO - Not taking screenshot here: see the one that was previously logged
[task 2018-07-13T15:16:00.200Z] 15:16:00     INFO - TEST-UNEXPECTED-FAIL | devtools/client/framework/test/browser_toolbox_telemetry_enter.js | start_state is correct - Got toolbox_show, expected initial_panel
[task 2018-07-13T15:16:00.201Z] 15:16:00     INFO - Stack trace:
[task 2018-07-13T15:16:00.201Z] 15:16:00     INFO - chrome://mochikit/content/browser-test.js:test_is:1305
[task 2018-07-13T15:16:00.208Z] 15:16:00     INFO - chrome://mochitests/content/browser/devtools/client/framework/test/browser_toolbox_telemetry_enter.js:checkResults:144
[task 2018-07-13T15:16:00.209Z] 15:16:00     INFO - chrome://mochitests/content/browser/devtools/client/framework/test/browser_toolbox_telemetry_enter.js:null:120
[task 2018-07-13T15:16:00.209Z] 15:16:00     INFO - chrome://mochikit/content/browser-test.js:Tester_execTest/<:1103
[task 2018-07-13T15:16:00.212Z] 15:16:00     INFO - chrome://mochikit/content/browser-test.js:Tester_execTest:1094
[task 2018-07-13T15:16:00.213Z] 15:16:00     INFO - chrome://mochikit/content/browser-test.js:nextTest/<:996
[task 2018-07-13T15:16:00.214Z] 15:16:00     INFO - chrome://mochikit/content/tests/SimpleTest/SimpleTest.js:SimpleTest.waitForFocus/waitForFocusInner/focusedOrLoaded/<:795
[task 2018-07-13T15:16:00.214Z] 15:16:00     INFO - Not taking screenshot here: see the one that was previously logged
Flags: needinfo?(moz-ian)
(Assignee)

Comment 18

8 months ago
(In reply to Ian Moody [:Kwan] (UTC+0) from comment #14)
> No try run since the change is too trivial to justify it.
Bah, famous last words.  I'll check out what that test is doing.
Comment hidden (mozreview-request)
(Assignee)

Comment 20

8 months ago
Ha, okay, I was just being dumb, and somehow missed that the ID passed around in that code isn't the same as the ID used in the markup, so we don't need the prefix, just the start and end anchors.  Apologies for the error.

Green try:
https://treeherder.mozilla.org/#/jobs?repo=try&revision=ccfb66b2d38936beda778acaa3cba432a0b66167
Flags: needinfo?(moz-ian)
Keywords: checkin-needed

Comment 21

8 months ago
Pushed by nerli@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/75ee38b6550f
Match regex against the entire panel ID. r=miker,rpl
Keywords: checkin-needed

Comment 22

8 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/75ee38b6550f
Status: ASSIGNED → RESOLVED
Last Resolved: 8 months ago
status-firefox63: affected → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla63
(Assignee)

Comment 23

8 months ago
(In reply to Ian Moody [:Kwan] (UTC+0) from comment #15)
> [Has the fix been verified in Nightly?]: Not yet, only on local build, but
> will do when Nighty's available.

Ember Inspector and attached sample extension tested in Nightly 20180714102053 04dd259d71db60341016eccf53ced43742319631, both panels load.

Comment 24

8 months ago
Posted image Bug1474379.png
I was able to reproduce this issue on Firefox 61.0.1 (20180704003137) under Win 7 64-bit and Mac OS X 10.13.3.

This issue is verified as fixed on Firefox 63.0a1 (20180716221418) under Win 7 64-bit and Mac OS X 10.13.3.

Please see the attached screenshot.

Updated

8 months ago
Status: RESOLVED → VERIFIED
status-firefox63: fixed → verified
Comment on attachment 8990780 [details]
Bug 1474379 - Match regex against the entire panel ID.

Better regexp, this should stop us from breaking some extensions.
OK for uplift to beta - this should land for beta 10.
Attachment #8990780 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Not a dot release driver, but I'll keep it on the radar for ride along consideration if the opportunity arises.
status-firefox61: affected → fix-optional
status-firefox-esr52: --- → unaffected
status-firefox-esr60: --- → unaffected
tracking-firefox61: ? → -

Comment 28

8 months ago
This issue is verified as fixed on Firefox 62.0b10 (20180719140244) under Win 7 64-bit and Mac OS X 10.13.3.
status-firefox62: fixed → verified
Flags: in-testsuite+
Comment on attachment 8990780 [details]
Bug 1474379 - Match regex against the entire panel ID.

Verified on Nightly and Beta. Approved for 61.0.2 as well.
Attachment #8990780 - Flags: approval-mozilla-release? → approval-mozilla-release+

Comment 30

8 months ago
bugherderuplift
https://hg.mozilla.org/releases/mozilla-release/rev/b5d39c025741
status-firefox61: fix-optional → fixed
Flags: qe-verify+

Comment 31

7 months ago
Posted image Bug1474379.png
This issue is verified as fixed on Firefox 61.0.2rc-build1 (20180807170231) under Win 7 64-bit and Mac OS X 10.13.3.

Please see the attached screenshot.

Updated

7 months ago
status-firefox61: fixed → verified
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.