Include Build ID in executable version string

RESOLVED WONTFIX

Status

()

Core
Build Config
--
enhancement
RESOLVED WONTFIX
16 years ago
5 years ago

People

(Reporter: Greg K., Unassigned)

Tracking

Trunk
Future
PowerPC
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
The Build ID should be included in the version string shown on the Mozilla
executable file itself for rapid identification.
(Reporter)

Comment 1

16 years ago
So, while the version string might currently show "1.0.0", it should show "1.0.0
(2002052305)".

I wonder if bug 25646 might be relevant.
Sounds like the mac version of the win32 versioning bug. --> jj
Assignee: seawood → jj

Comment 3

16 years ago
We never included the build ID in the version string (at least on mac). This is
a feature enhancement that will most likely only happen after 1.0 release.
Severity: normal → enhancement
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Target Milestone: --- → Future

Updated

15 years ago
Blocks: 80613

Comment 4

15 years ago
This problem doesn't only affect the version number that appears in the "get
info" box, but also affects the Dock and internet preferences on MacOS X.  See
bug 207726 for a detailed description of what I'm referring to.

Comment 5

15 years ago
engineer gone, wontfix.  if you want it, reopen the bug and reassign it to 
yourself.
Status: ASSIGNED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WONTFIX
Product: Browser → Seamonkey
(Reporter)

Comment 6

12 years ago
Reopening since "engineer gone" is not a valid reason for wontfixing a bug (at least not in the post-Netscape era), and the meta blocked bug is still open.
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---
(Reporter)

Comment 7

12 years ago
Moving to Core and defaulting assignee and QA contact.
Assignee: jj.enser → nobody
Status: REOPENED → NEW
Component: Build Config → Build Config
Product: Mozilla Application Suite → Core
QA Contact: granrosebugs → build-config

Comment 8

5 years ago
I'm going to assert this isn't going to happen.
Status: NEW → RESOLVED
Last Resolved: 15 years ago5 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.