Closed Bug 1474633 Opened Last year Closed Last year

Crash in java.lang.NullPointerException: Attempt to invoke interface method 'void org.mozilla.gecko.firstrun.FirstrunPanel$PagerNavigation.next()' on a null object reference at org.mozilla.gecko.firstrun.FirstrunPanel$1.onClick(FirstrunPanel.java)

Categories

(Firefox for Android :: First Run, defect, critical)

Firefox 62
Unspecified
Android
defect
Not set
critical

Tracking

()

RESOLVED FIXED
Firefox 63
Tracking Status
firefox61 --- wontfix
firefox62 --- fixed
firefox63 --- fixed

People

(Reporter: marcia, Assigned: vlad.baicu)

Details

(Keywords: crash, regression)

Crash Data

Attachments

(1 file)

This bug was filed from the Socorro interface and is
report bp-c72f82ba-da7e-4a09-9472-578e60180709.
=============================================================

Seen while looking at 62 beta crash stats: https://bit.ly/2KOnF6M. Becoming more noticeable in 62b5 on certain devices.

Top 10 frames of crashing thread:

0 libxul.so GeckoAppShellSupport::ReportJavaCrash widget/android/nsAppShell.cpp:280
1 dalvik-main space (deleted) dalvik-main space @0x201a797e 
2 libxul.so void mozilla::jni::NativeStub<mozilla::java::GeckoAppShell::ReportJavaCrash_t, GeckoAppShellSupport, mozilla::jni::Args<mozilla::jni::Ref<mozilla::jni::TypedObject<_jthrowable*>, _jthrowable*> const&, mozilla::jni::StringParam const&> >::Wrap<&GeckoAppShellSupport::ReportJavaCrash> widget/android/jni/Natives.h:778
3 dalvik-alloc space (deleted) dalvik-alloc space @0xea9e 
4 data@app@org.mozilla.firefox_beta-1@base.apk@classes.dex data@app@org.mozilla.firefox_beta-1@base.apk@classes.dex@0x1018279 
5 dalvik-alloc space (deleted) dalvik-alloc space @0xd05e 
6 dalvik-main space (deleted) dalvik-main space @0x20013bfe 
7 dalvik-main space (deleted) dalvik-main space @0x201a797e 
8 dalvik-main space (deleted) dalvik-main space @0x201d8c3e 
9 dalvik-main space (deleted) dalvik-main space @0x201d8c3e 

=============================================================
Here are a few of the URLs that show up:

*about:logins 
*about:accounts?action=signin&entrypoint=firstrun
This is still showing up as a startup crash in beta 62 in a fairly high volume (100+ crashes/week). 
Cristian, can you help out? Thanks.
Flags: needinfo?(cchiorean)
Assignee: nobody → vlad.baicu
Status: NEW → ASSIGNED
Flags: needinfo?(cchiorean)
I tried to reproduce this but was not able at all for Samsung Galaxy S8+ (Android 9) and Sony Xperia Z5 (Android 7.0)
Though on Pixel 2 (Android 9) - see here - https://youtu.be/nEonAOucJ20
I was just able to reproduce this crash on nightly. I cleared the app data, surfed around. Then left nightly idle. The next time I launched I saw the first run again, and then fennec crashed.
What device did you use Marcia?
Flags: needinfo?(mozillamarcia.knous)
(In reply to Ioana Chiorean from comment #5)
> What device did you use Marcia?

Pixel 2 running Android Pie.
Flags: needinfo?(mozillamarcia.knous)
Check if pager navigation is null before calling it.
I tried hard to reproduce this issue on multiple devices and with various scenarios however I had no success with it. Including a Pixel 2 device. I submitted a speculative fix which should prevent the crash from occuring but I was unable to find out what exactly was causing it. At worst the next button will do nothing which should still be better than this crash.
Comment on attachment 9003503 [details]
Bug 1474633 - Check if pager navigation is null before calling it. r?sdawsani

Jim Chen [:jchen] [:darchons] has approved the revision.
Attachment #9003503 - Flags: review+
Keywords: checkin-needed
Pushed by ebalazs@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/e0155c8c93a9
Check if pager navigation is null before calling it. r=jchen
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/e0155c8c93a9
Status: ASSIGNED → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → Firefox 63
Comment on attachment 9003503 [details]
Bug 1474633 - Check if pager navigation is null before calling it. r?sdawsani

Approval Request Comment
[Feature/Bug causing the regression]: Firstrun pager navigation causes crashes in some scenarios.
[User impact if declined]: Users will continue to experience crashes
[Is this code covered by automated tests?]: No
[Has the fix been verified in Nightly?]: No
[Needs manual test from QE? If yes, steps to reproduce]: The issue appears randomly at startup on some devices. I believe a QA verify wouldn't hurt.
[List of other uplifts needed for the feature/fix]: -
[Is the change risky?]: No
[Why is the change risky/not risky?]: The change is not risky because we're simply checking if the pager navigation is null before calling it. 
[String changes made/needed]: -
Attachment #9003503 - Flags: approval-mozilla-beta?
Comment on attachment 9003503 [details]
Bug 1474633 - Check if pager navigation is null before calling it. r?sdawsani

Adds a null check to fix a crash. Approved for Fennec 62.0b21.
Attachment #9003503 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Tried to verify this on 62.0b21, but I can't reproduce the bug on previous builds with a Pixel device. I'll NI Ioana, maybe she can have a look since she was closer to reproduce this.
Flags: needinfo?(ioana.chiorean)
I am not able to reproduce it at all - Pixel 2 - Android P 

(In reply to Marcia Knous [:marcia - needinfo? me] from comment #4)
> I was just able to reproduce this crash on nightly. I cleared the app data,
> surfed around. Then left nightly idle. The next time I launched I saw the
> first run again, and then fennec crashed.

Marcia, are you still seeing this?
Flags: needinfo?(ioana.chiorean)
Flags: needinfo?(mozillamarcia.knous)
(In reply to Ioana Chiorean from comment #16)
> I am not able to reproduce it at all - Pixel 2 - Android P 
> 
> (In reply to Marcia Knous [:marcia - needinfo? me] from comment #4)
> > I was just able to reproduce this crash on nightly. I cleared the app data,
> > surfed around. Then left nightly idle. The next time I launched I saw the
> > first run again, and then fennec crashed.
> 
> Marcia, are you still seeing this?

I have not been able to reproduce it since Comment 6.
Flags: needinfo?(mozillamarcia.knous)
You need to log in before you can comment on or make changes to this bug.