A TP icon is shown on about: pages if you've visited a tracking website before

VERIFIED FIXED in Firefox 62

Status

()

defect
P1
normal
VERIFIED FIXED
Last year
Last year

People

(Reporter: darkspirit, Assigned: johannh)

Tracking

({nightly-community, regression})

Trunk
Firefox 63
x86_64
All
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox-esr52 unaffected, firefox-esr60 unaffected, firefox61 unaffected, firefox62 fixed, firefox63 verified)

Details

Attachments

(1 attachment)

mozregression --launch 2018-07-11 --pref privacy.trackingprotection.enabled:true startup.homepage_welcome_url:'https://bugzilla.mozilla.org/|about:buildconfig|https://www.startpage.com/'
1. Reload BMO, click X on the TP intro box.
2. Switch to about:buildconfig: It has a TP icon (bug).
3. Switch to StartPage and back to about:buildconfig: The TP icon is gone.
4. Switch to BMO and back to about:buildconfig: The TP icon is back.

In rarely cases BMO doesn't seem to have an active Google Analytics script(?), but mostly it has one (and even illegally in Germany if DNT:1 is sent: bug 1462851).

mozregression --good 2018-06-01 --bad 2018-07-11 --pref privacy.trackingprotection.enabled:true startup.homepage_welcome_url:'https://bugzilla.mozilla.org/|about:buildconfig|https://www.startpage.com/'
< 21:58.85 INFO: Last good revision: c1561409e431468169a6f22acaece537fe3de934
> 21:58.85 INFO: First bad revision: 6e0fc38940b484f165c4e76551d1bc91ded92ab7
> 21:58.85 INFO: Pushlog:
> https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=c1561409e431468169a6f22acaece537fe3de934&tochange=6e0fc38940b484f165c4e76551d1bc91ded92ab7

> 6e0fc38940b4	Johann Hofmann — Bug 1470020 - Part 4 - Don't handle Tracking Protection UI on file: and about: URIs. r=florian
> 00c94772a661	Johann Hofmann — Bug 1470020 - Part 3 - Updates to TP copy in the identity popup. r=florian
> 74475cd5a233	Johann Hofmann — Bug 1470020 - Part 2 - Add specific states for when the user has added a TP exception to the TP section of the identity popup. r=florian
> b7af8264a336	Johann Hofmann — Bug 1470020 - Part 1 - Don't show the "Enable Protection" button when it links to the TP preferences. r=florian

Side note: In general, thank you for polishing up tracking protection so nicely! :)
Ah, thanks for catching this. This should affect all about: pages if I'm not mistaken. The fix should be easy and is already in bug 1471713 but we should make a separate upliftable patch in this bug as well...
Assignee: nobody → jhofmann
Status: NEW → ASSIGNED
Priority: -- → P1
Summary: A TP icon is shown on about:buildconfig if you've visited a tracking website before → A TP icon is shown on about: pages if you've visited a tracking website before
Comment on attachment 8991464 [details]
Bug 1474891 - Reset tracking protection state when visiting about: pages.

https://reviewboard.mozilla.org/r/256358/#review263406

thanks, it does what it's supposed to.
Attachment #8991464 - Flags: review?(ewright) → review+
Pushed by jhofmann@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/3e71248ff093
Reset tracking protection state when visiting about: pages. r=ewright
https://hg.mozilla.org/mozilla-central/rev/3e71248ff093
Status: ASSIGNED → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → Firefox 63
Comment on attachment 8991464 [details]
Bug 1474891 - Reset tracking protection state when visiting about: pages.

Approval Request Comment
[Feature/Bug causing the regression]: Bug 1470020
[User impact if declined]: Visiting a page with tracking protection and after that an about: page will continue to show the TP shield
[Is this code covered by automated tests?]: Not this specific case, but the TP shield states are otherwise well covered.
[Has the fix been verified in Nightly?]: Not yet
[Needs manual test from QE? If yes, steps to reproduce]: With TP on, open a page with trackers then go to about:preferences in the same tab.
[List of other uplifts needed for the feature/fix]: None
[Is the change risky?]: No
[Why is the change risky/not risky?]: One-liner that simply removes an attribute from an element that should not be applied.
[String changes made/needed]: None
Attachment #8991464 - Flags: approval-mozilla-beta?
darkspirit, since you found the issue, would you mind verifying this fix in nightly? Thanks!
Flags: needinfo?(jan)
(In reply to Jan Andre Ikenmeyer [:darkspirit] from comment #0)
> mozregression --launch 2018-07-11 --pref privacy.trackingprotection.enabled:true startup.homepage_welcome_url:'https://bugzilla.mozilla.org/|about:buildconfig|https://www.startpage.com/'
> 1. Reload BMO, click X on the TP intro box.
> 2. Switch to about:buildconfig: It has a TP icon (bug).
> 3. Switch to StartPage and back to about:buildconfig: The TP icon is gone.
> 4. Switch to BMO and back to about:buildconfig: The TP icon is back.

mozregression --launch 2018-07-13 --pref privacy.trackingprotection.enabled:true startup.homepage_welcome_url:'https://bugzilla.mozilla.org/|about:buildconfig|https://www.startpage.com/'

Verified fixed on Windows 10 and Debian Testing. Thank you!
Status: RESOLVED → VERIFIED
Has Regression Range: --- → yes
Has STR: --- → yes
Flags: needinfo?(jan)
OS: Windows 10 → All
Comment on attachment 8991464 [details]
Bug 1474891 - Reset tracking protection state when visiting about: pages.

Thanks very much! 
Fix verified by reporter, let's uplift this for beta 9.
Attachment #8991464 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
You need to log in before you can comment on or make changes to this bug.