Closed Bug 1476285 Opened 4 years ago Closed 4 years ago

The close button for snippets is showing up in the middle of the snippets on Nightly

Categories

(Snippets Graveyard :: General, defect)

defect
Not set
normal

Tracking

(firefox63+ fixed)

RESOLVED FIXED
Tracking Status
firefox63 + fixed

People

(Reporter: ehsan.akhgari, Assigned: andreio)

References

Details

(Keywords: regression, regressionwindow-wanted)

Attachments

(1 file)

Attached image Screenshot
Please see the screenshot for how the close button is positioned right now.
Noticed this recently as well.

STR:

1) Open a new tab (about:newtab)
2) Hover the snippet at the bottom of the page

expected result:
The close button [X] should be located at the right side of the banner

tested result: 
as Ehsan posted, the [X] button is in the center of the snippet banner.
Thanks for reporting.

Kate, Andrei did something change in AS in nightly that would have caused this behavior? We're serving the same template on all Release, Beta and Nightly but only Nightly gets the misplaced close button.
Flags: needinfo?(khudson)
Flags: needinfo?(andrei.br92)
Assignee: nobody → andrei.br92
Flags: needinfo?(andrei.br92)
See Also: → 1464782
Tracked down the issue to the renaming of the offset-* properties to inset-* in bug 1464782. There was a backport to Activity Stream but snippet code is external to our repository.
A pull request was made to update the snippets css [0] and use both declarations (in order to support both release and nightly channels).

[0] https://github.com/mozmeao/snippets-service/pull/610
Flags: needinfo?(khudson)
Should we close this since this requires no changes in Firefox / affects code outside of Firefox only? What's the right tracking flag to set for that?
There might be some stuff to fix up here too: https://github.com/mozmeao/snippets
(In reply to Kate Hudson :k88hudson from comment #4)
> Should we close this since this requires no changes in Firefox / affects
> code outside of Firefox only? What's the right tracking flag to set for that?

This is under the snippets component, so lets keep it. Feel free to remove the tracking flags, I don't use those
(In reply to Kate Hudson :k88hudson from comment #4)
> Should we close this since this requires no changes in Firefox / affects
> code outside of Firefox only? What's the right tracking flag to set for that?

We are tracking that for Firefox 63 because this is a regression that affects Firefox starting with this version and from an end-user perspective, snippets are part of the product. Once this is fixed in GitHub, this bug should be marked as fixed and the Firefox63 tracking flag changed from affected to fixed.
Fixed in https://github.com/mozmeao/snippets-service/commit/ac6711b41f59983813ac29f727ebe32d0c420115
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Product: Snippets → Snippets Graveyard
You need to log in before you can comment on or make changes to this bug.