Prevent expired sponsored stories from showing to users

RESOLVED FIXED in Firefox 65

Status

()

defect
P1
normal
RESOLVED FIXED
10 months ago
5 months ago

People

(Reporter: kenny, Assigned: gsuntop)

Tracking

unspecified
Firefox 65
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox61 unaffected, firefox62 wontfix, firefox63 wontfix, firefox64 wontfix, firefox65 fixed)

Details

Attachments

(1 attachment)

Reporter

Description

10 months ago
When a user launches Firefox for the first time in a few days or weeks, they can see sponsored content (spocs) for campaigns that ended long ago because the Pocket recommendations feed response hasn't had a chance to refresh before the first tab is rendered.

To prevent this, Pocket will include an `expiration_timestamp` with each spoc in the /v3/firefox/global-recs response, and would need that timestamp checked as part of the filtration logic when deciding whether a spoc is eligible to be shown.
Assignee: nobody → sdowne
Iteration: --- → 63.3 - Aug 6
Priority: -- → P1
Iteration: 63.3 - Aug 6 → ---
Assignee: sdowne → gsuntop
Assignee

Comment 1

7 months ago
Is it correct to assume that `expiration_timestamp` is the number of seconds elapsed since January 1, 1970 00:00:00 UTC?
Flags: needinfo?(sdowne)
Assignee

Comment 2

7 months ago
Confirmed with kaiser on Slack.
Flags: needinfo?(sdowne)

Comment 4

6 months ago
Commit pushed to master at https://github.com/mozilla/activity-stream

https://github.com/mozilla/activity-stream/commit/71c92b34b0e51dc147a7fa653880a2ee2298e7d9
Fix Bug 1476458 - Prevent expired sponsored stories from showing to users (#4549)

Updated

6 months ago
Status: NEW → RESOLVED
Last Resolved: 6 months ago
Resolution: --- → FIXED

Updated

6 months ago
Blocks: 1509565
You need to log in before you can comment on or make changes to this bug.