Closed Bug 14765 Opened 20 years ago Closed 20 years ago

Contextual menus - on 2nd click they become 2x as long

Categories

(SeaMonkey :: UI Design, defect, P2)

defect

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: cpratt, Assigned: slamm)

Details

(Whiteboard: Fix ready.)

Build ID: 1999092308
Platform: Windows NT

To reproduce:
- Launch apprunner
- Open the Manage Bookmarks window
- Right-click on a bookmark
- Right-click a second time on the same bookmark

Result: When the contextual menu comes up the first time it's fine. When you
click a second time, it doubles in length and displays every item twice
(a-b-c-a-b-c and not a-a-b-b-c-c).
QA Contact: leger → cpratt
this is still happening on 10/28 builds. don, who owns contextual menus?
Assignee: don → law
Component: Browser-General → XPApps
Priority: P3 → P2
Target Milestone: M12
Bill, is this a bug for you or for Steve?
Assignee: law → slamm
This behavior seems to be limited to the Manage Bookmarks window so I'm
re-assigning it to slamm.
QA Contact: cpratt → elig
[Contextual menu bug --- QA Assigning to self.]
Status: NEW → ASSIGNED
I do not see any context menus in manage bookmarks right now. I will have to fix
that first.
Ah ha! You have to select an item in order to get a context menu. It should
always select the item under the mouse when you post the context menu.
I see the double items too, so I will clean that up as well.
I have a fix for this now. I will check it in when I get it reviewed.
Blocks: 18951
Whiteboard: Fix ready.
Status: ASSIGNED → RESOLVED
Closed: 20 years ago
Resolution: --- → FIXED
I checked in a fix.
QA Contact: elig → sairuh
Hey, Sarah --- your bug. ;)
Status: RESOLVED → VERIFIED
verified as fixed on NT w/99121915-m13.
No longer blocks: 18951
Product: Core → Mozilla Application Suite
You need to log in before you can comment on or make changes to this bug.