Open Bug 1476515 Opened 3 years ago Updated 2 months ago

META: Implementation of Web Share Target API

Categories

(Core :: DOM: Core & HTML, enhancement, P3)

enhancement

Tracking

()

UNCONFIRMED

People

(Reporter: pierre, Unassigned)

References

(Depends on 2 open bugs, Blocks 1 open bug)

Details

(Keywords: dev-doc-needed, parity-chrome)

User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/67.0.3396.99 Safari/537.36




Expected results:

This specification defines an API that allows websites to declare themselves as web share targets, which can receive shared content from either the Web Share API, or system events (e.g., shares from native apps).

I think it would be a great addition on mobile, specifically for PWA.
Implementation is on its way for Chrome (currently in Chrome Canary for Android).

https://wicg.github.io/web-share-target/
Status: UNCONFIRMED → RESOLVED
Closed: 3 years ago
Component: Untriaged → Web Apps
Keywords: parity-chrome
Product: Firefox → Firefox for Android
Resolution: --- → DUPLICATE
Duplicate of bug: 1402369
Even though I agree there is already a ticket about the Web Share API (navigator.share), I don't think it covers the share target API (as documented on https://wicg.github.io/web-share-target/). 

Maybe interesting to either merge both tickets or keep this one for this specific spec.
(In reply to Pierre Paridans from comment #2)
> Even though I agree there is already a ticket about the Web Share API
> (navigator.share), I don't think it covers the share target API (as
> documented on https://wicg.github.io/web-share-target/). 
(In reply to Matt Giuca from bug 1402369, comment #6)
> Keep in mind we are talking about the Web Share API (navigator.share),
> and not share targets (which are mostly separate, documented at https://github.com/WICG/web-share-target).

Sorry about incorrectly marking this as a duplicate.
Severity: normal → enhancement
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
OS: Unspecified → Android
Hardware: Unspecified → ARM
Component: Web Apps → DOM: Core & HTML
OS: Android → Unspecified
Priority: -- → P3
Product: Firefox for Android → Core
Hardware: ARM → Unspecified
Summary: Implementation of Web Share Target API → META: Implementation of Web Share Target API
Version: Trunk → unspecified
Depends on: 1586160
Depends on: 1586157, 1586158
Blocks: 1586160
No longer depends on: 1586160
You need to log in before you can comment on or make changes to this bug.