Closed Bug 1476664 Opened 3 years ago Closed 1 month ago

The searched string is not displayed as highlighted above the "Add" button in the preferences page

Categories

(Firefox :: Preferences, defect, P3)

defect

Tracking

()

RESOLVED FIXED
95 Branch
Tracking Status
firefox-esr60 --- unaffected
firefox-esr78 --- wontfix
firefox-esr91 --- wontfix
firefox61 --- wontfix
firefox62 --- wontfix
firefox63 --- wontfix
firefox64 --- wontfix
firefox93 --- wontfix
firefox94 --- wontfix
firefox95 --- fixed

People

(Reporter: mberlinger, Assigned: kpatenio)

References

Details

(Keywords: regression)

Attachments

(2 files, 1 obsolete file)

Attached video Search bug.mov
[Affected versions]:
Firefox 63.0a1 (BuildId:20180718100918).
Firefox 62.0b9 (BuildId:20180713213322).
Firefox 61.0.1 (BuildId:20180704003137).

[Unaffected versions]:
Firefox 60.1.0 esr (BuildId:20180621121604).

[Affected platforms]:
Windows 10 64bit.
macOS 10.13.4
Ubuntu 16.04 64bit.

[Steps to reproduce]:
1. Launch Firefox.
2. Go to about:preferences.
3. Write "Organiza" in the "Find in options" search field.
4. Go to "Saved Addresses".

[Expected result]:
The string entered in step 3 is displayed as highlighted above the "Add" button in the "Saved Addresses" panel.

[Actual result]:
The searched string is not displayed as highlighted above the "Add" button.

[Regression range]:
This seems to be a regression:
Last good revision: e62d73ef396c32ca930897eb95d328e2ac15a901
First bad revision: a831178ed112be4db3c867876b99e61d22bdbc7a

Pushlog:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=e62d73ef396c32ca930897eb95d328e2ac15a901&tochange=a831178ed112be4db3c867876b99e61d22bdbc7a

[Additional information]:
For further information regarding this issue please observe the attached screencast.
Please note that the searched string is displayed highlighted above the "Add" button only after accessing the "Add New Address" panel by clicking the "Add" button and going back to the "Saved Addresses" panel again via the "Cancel" button.
Hi Zibi!

Can you please have a look into this?

Thanks!
Flags: needinfo?(gandalf)
Has Regression Range: --- → yes
Has STR: --- → yes
Priority: -- → P1
The grapevine mentioned a day or two that gandalf is/was on PTO. Jared, could you take a look? AFAICT we're shipping this in the US, but I know very little about it as I never see it, given we don't ship it in most other places. It's not as trivial as I first thought, because the form fill dialog is written in HTML so it's not just a question of missing fluent IDs or something...
Flags: needinfo?(jaws)
Priority: P1 → P3
Gandalf, Jared, any update on this issue?
These formfill dialogs don't use Fluent. Switching over to Fluent should fix it and would be the right direction to move. This appears to only affect the formfill dialogs.
Flags: needinfo?(jaws)
Flags: needinfo?(gandalf)
Too late to fix in 63. We could still take a patch for 65 and potentially for 64.
Assignee: nobody → kpatenio
Status: NEW → ASSIGNED
Attachment #9244007 - Attachment is obsolete: true

Submitted a new WIP patch addressing the issue.

It appears that this bug occurs due to the way we call searchWithinNode before creating the tooltips for the Add button (it is an asynchronous function).

Fluent migrations will not be made for this fix.

Attachment #9246947 - Attachment description: WIP: Bug 1476664 - fix search term tooltip for Add button in saved addresses dialog → Bug 1476664 - fix search term tooltip for Add button in saved addresses dialog
Pushed by jwein@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/c2a16b8370fe
fix search term tooltip for Add button in saved addresses dialog r=preferences-reviewers,jaws
Status: ASSIGNED → RESOLVED
Closed: 1 month ago
Resolution: --- → FIXED
Target Milestone: --- → 95 Branch
You need to log in before you can comment on or make changes to this bug.