Crash in java.lang.IllegalStateException: FragmentManager is already executing transactions at android.support.v4.app.FragmentManagerImpl.ensureExecReady(FragmentManager.java)

VERIFIED FIXED in Firefox 63

Status

()

--
critical
VERIFIED FIXED
5 months ago
2 months ago

People

(Reporter: marcia, Assigned: petru)

Tracking

(4 keywords)

Trunk
Firefox 63
Unspecified
Android
crash, regression, reproducible, topcrash
Points:
---

Firefox Tracking Flags

(firefox-esr52 unaffected, firefox-esr60 unaffected, firefox61 unaffected, firefox62 unaffected, firefox63 verified)

Details

(Whiteboard: [priority:high], crash signature)

Attachments

(1 attachment)

This bug was filed from the Socorro interface and is
report bp-054abb3e-dd18-4596-8857-f7ab00180718.
=============================================================

Unsure where to file this, but this might be another regression from the API 26 work: https://bit.ly/2msCYDN.

One comment: crashed on first opening. 

Top 10 frames of crashing thread:

0 libxul.so GeckoAppShellSupport::ReportJavaCrash widget/android/nsAppShell.cpp:280
1 libxul.so void mozilla::jni::NativeStub<mozilla::java::GeckoAppShell::ReportJavaCrash_t, GeckoAppShellSupport, mozilla::jni::Args<mozilla::jni::Ref<mozilla::jni::TypedObject<_jthrowable*>, _jthrowable*> const&, mozilla::jni::StringParam const&> >::Wrap<&GeckoAppShellSupport::ReportJavaCrash> widget/android/jni/Natives.h:778
2 base.odex base.odex@0xba26b 
3 dalvik-LinearAlloc (deleted) dalvik-LinearAlloc @0x4f2a 
4 dalvik-main space (region space) (deleted) dalvik-main space @0x142f116 
5 dalvik-main space (region space) (deleted) dalvik-main space @0x205cf6 
6 dalvik-main space (region space) (deleted) dalvik-main space @0x254db6 
7 libart.so libart.so@0x3dcce1 
8 dalvik-main space (region space) (deleted) dalvik-main space @0x205cf6 
9 dalvik-main space (region space) (deleted) dalvik-main space @0x254db6 

=============================================================
From the top part of the Java stack:

java.lang.IllegalStateException: FragmentManager is already executing transactions
	at android.support.v4.app.FragmentManagerImpl.ensureExecReady(FragmentManager.java:2167)
	at android.support.v4.app.FragmentManagerImpl.execPendingActions(FragmentManager.java:2223)
	at android.support.v4.app.FragmentManagerImpl.popBackStackImmediate(FragmentManager.java:819)
	at org.mozilla.gecko.tabs.TabHistoryFragment.dismiss(TabHistoryFragment.java:147)
	at org.mozilla.gecko.tabs.TabHistoryFragment.onPause(TabHistoryFragment.java:108)
	at android.support.v4.app.Fragment.performPause(Fragment.java:2542)
	at android.support.v4.app.FragmentManagerImpl.moveToState(FragmentManager.java:1476)
	at android.support.v4.app.FragmentManagerImpl.moveFragmentToExpectedState(FragmentManager.java:1740)
	at android.support.v4.app.BackStackRecord.executePopOps(BackStackRecord.java:853)
	at android.support.v4.app.FragmentManagerImpl.executeOps(FragmentManager.java:2577)
	at android.support.v4.app.FragmentManagerImpl.executeOpsTogether(FragmentManager.java:2367)
	at android.support.v4.app.FragmentManagerImpl.removeRedundantOperationsAndExecute(FragmentManager.java:2322)
	at android.support.v4.app.FragmentManagerImpl.popBackStackImmediate(FragmentManager.java:851)
	at android.support.v4.app.FragmentManagerImpl.popBackStackImmediate(FragmentManager.java:794)
	at android.support.v4.app.FragmentActivity.onBackPressed(FragmentActivity.java:174)
Currently the #5 top browser crash on nightly.
Keywords: topcrash
Whiteboard: --do_not_change--[priority:high]
I can repro this seemingly reliably by holding the phone's back button to bring up the menu, then hitting back again.

bp-8ee5ea2c-eeeb-42d3-b05b-bb4d10180720
(In reply to Ian Moody [:Kwan] (UTC+0) from comment #3)
> I can repro this seemingly reliably by holding the phone's back button to
> bring up the menu, then hitting back again.
> 
> bp-8ee5ea2c-eeeb-42d3-b05b-bb4d10180720

Thanks for the STR! I can also reproduce on my Pixel 2 100% with these steps.
Keywords: reproducible
(Assignee)

Updated

5 months ago
Assignee: nobody → petru.lingurar
Status: NEW → ASSIGNED
status-firefox62: --- → ?
Whiteboard: --do_not_change--[priority:high] → --do_not_change--[priority:high][geckoview:klar]
Comment hidden (mozreview-request)

Comment 6

5 months ago
Also reproducing with the STR. Petru feel free to Ni me when you have the fix.
Attachment #8994420 - Flags: review?(sdaswani) → review?(nchen)

Comment 7

5 months ago
mozreview-review
Comment on attachment 8994420 [details]
Bug 1476710 - Use childFragmentmanager when dismissing TabHistoryFragment;

https://reviewboard.mozilla.org/r/258974/#review266468
Attachment #8994420 - Flags: review?(nchen) → review+
(Assignee)

Updated

5 months ago
Keywords: checkin-needed

Comment 8

5 months ago
Pushed by archaeopteryx@coole-files.de:
https://hg.mozilla.org/integration/autoland/rev/78a98c31897a
Use childFragmentmanager when dismissing TabHistoryFragment; r=jchen
Keywords: checkin-needed

Comment 9

5 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/78a98c31897a
Status: ASSIGNED → RESOLVED
Last Resolved: 5 months ago
status-firefox63: affected → fixed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 63
(Assignee)

Updated

5 months ago
Flags: qe-verify+
(Assignee)

Comment 10

5 months ago
Next Nightly build will contains my patch.
Would appreciate if you could test to see if the issue was fixed.
Flags: needinfo?(ioana.chiorean)
Whiteboard: --do_not_change--[priority:high][geckoview:klar] → [priority:high]
Fennec <= 62 is unaffected because this is a regression from the API 26 work in 63 Nightly.
status-firefox61: --- → unaffected
status-firefox62: ? → unaffected
status-firefox-esr52: --- → unaffected
status-firefox-esr60: --- → unaffected

Comment 12

4 months ago
Verified as fixed on Nightly 63 with the STR in comment 3.
Devices:
Huawei Nexus 6P (Android 8.1.0)
Samsung Galaxy Tab 3 (Android 8.0)
Google Pixel (Android P Beta)
HTC Desire 820 (Android 6.0.1)
Status: RESOLVED → VERIFIED
status-firefox63: fixed → verified
Flags: qe-verify+
Flags: needinfo?(ioana.chiorean)

Updated

2 months ago
Depends on: 1498854
You need to log in before you can comment on or make changes to this bug.