Tasks are not displayed anymore in calendar views even if enabled in the view menu

RESOLVED FIXED in 6.9

Status

defect
RESOLVED FIXED
10 months ago
2 months ago

People

(Reporter: MakeMyDay, Assigned: darktrojan)

Tracking

(Blocks 1 bug, {regression})

Lightning 6.5
Dependency tree / graph

Details

Attachments

(1 attachment)

Reporter

Description

10 months ago
Tasks are not displayed anymore in the calendar views if you have enabled the respective menu item at View > Calendar > Current View > Tasks in View

There is no related messages in the error console and the same tasks are displayed properly in task view as well as the today pane.

This still works in TB 60 / Lightning 6.2 b10, so it looks like a regression of the Lightning wx conversion.
Reporter

Comment 1

10 months ago
This is a race condition when loading the overlays. The view relies on the toolbar setting being available already to apply the filter for getting the items properly. Since that is not yet present when loading the view, it fails to display the tasks in view. This will be resolved by bug 1477958, so marking this as duplicate.
Status: NEW → RESOLVED
Last Resolved: 10 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1477958
Reporter

Updated

10 months ago
Blocks: 1478608
Reporter

Comment 2

9 months ago
Reopening since there's currently no active work on bug 1477958, so a separate resolution of the issue might be appropriate.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Reporter

Updated

9 months ago
Status: REOPENED → NEW
Assignee

Comment 3

2 months ago

Still seeing this?

Flags: needinfo?(makemyday)
Reporter

Comment 4

2 months ago

Yes, still present. If you can create a task with a start date/time, it should show up in the calendar view.

Flags: needinfo?(makemyday)
Assignee

Comment 5

2 months ago

Huh. Well, it works every time for me.

Using Thunderbird 67.0a1 (BuildID 20190317094532) with Lightning 6.9.

I do see tasks in month and multiweek view.
I do not see tasks in week view and day view.
Error Console shows:

NS_NOINTERFACE: Component returned failure code: 0x80004002 (NS_NOINTERFACE) [nsISupports.QueryInterface]
computeEventMap chrome://calendar/content/calendar-multiday-view.xml:887
forEach self-hosted:262
computeEventMap chrome://calendar/content/calendar-multiday-view.xml:886
relayout chrome://calendar/content/calendar-multiday-view.xml:705
mEventMapTimeout chrome://calendar/content/calendar-multiday-view.xml:603

Assignee

Updated

2 months ago
Assignee: nobody → geoff
Status: NEW → ASSIGNED
Assignee

Comment 7

2 months ago

Okay, I broke this in February trying to fix a major bustage, but the bug report is from last July. Go figure.

Attachment #9053168 - Flags: review?(philipp)
Attachment #9053168 - Flags: review?(makemyday)

Updated

2 months ago
Attachment #9053168 - Flags: approval-calendar-beta?(philipp)
Attachment #9053168 - Flags: review?(philipp)
Attachment #9053168 - Flags: review?(makemyday)
Attachment #9053168 - Flags: review+
Attachment #9053168 - Flags: approval-calendar-beta?(philipp)
Attachment #9053168 - Flags: approval-calendar-beta+

Updated

2 months ago
Keywords: checkin-needed

Comment 8

2 months ago

Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/1b27e8759d82
Fix tasks displayed in day view and week view. r=philipp

Status: ASSIGNED → RESOLVED
Last Resolved: 10 months ago2 months ago
Keywords: checkin-needed
Resolution: --- → FIXED

Updated

2 months ago
Target Milestone: --- → 7.0
You need to log in before you can comment on or make changes to this bug.